Trouble instaling drivers for telemetry radio

Hello, I am tring to install these drivers

in order too be able to make my telemetry radio work. If you don’t know what I am talking about I have these https://docs.holybro.com/radio/sik-telemetry-radio-v3

These worked when I was on windows, but I think that I need to setup and install some drivers on linux, and I think that these are the ones I need. I already tried, don’t know if I managed to install them because it still doesn’t work. I am a beginner. If you need any more info about something just ask, any help will be appreciated

libftd2xx in the AUR looks to be the very same driver you’re trying to install (the drivers link in the PDF point to here, which lists the same driver for Linux).

yay -S libftd2xx

Thanks, btw, I saw this in the docs of one of the software I am using:

Ubuntu comes with a serial modem manager that interferes with any robotics related use of a serial port (or USB serial). Before installing QGroundControl you should remove the modem manager and grant yourself permissions to access the serial port. You also need to install GStreamer in order to support video streaming.

Before installing QGroundControl for the first time:

On the command prompt enter:
    sudo usermod -a -G dialout $USER
    sudo apt-get remove modemmanager -y
    sudo apt install gstreamer1.0-plugins-bad gstreamer1.0-libav gstreamer1.0-gl -y
    sudo apt install libfuse2 -y
    sudo apt install libxcb-xinerama0 libxkbcommon-x11-0 libxcb-cursor0 -y

    Logout and login again to enable the change to user permissions.

To install QGroundControl:

Download QGroundControl.AppImage.
Install (and run) using the terminal commands:
chmod +x ./QGroundControl.AppImage
./QGroundControl.AppImage  (or double click)

Does Endeavour OS have that kind of serial modem? If yes, how do I disable it?

I suggest seeing if it works or not, first, before removing things that you may not need to.

Assuming modemmanager from Ubuntu repositories, is the same as modemmanager in the Arch packages, then yes, it appears this is installed by default.

Uninstalling it might be as simple as:

sudo pacman -R modemmanager

However, I suspect there will be other packages depending on this in a chain of sorts and it won’t let you uninstall it easily, because eventually you end up needing to uninstall some important parts of your system.

You can side step these dependency checks, but I must stress, this is not advisable, as it’s like taking a gear out of a clock and expecting it to work as usual. If you proceed, please understand you are taking a risk, and it may break something/s.

sudo pacman -R --nodeps modemmanager