Trouble adding second drive to Grub

I have two hard drives:

│    259:0    0 465.8G  0 disk 
│    259:1    0   300M  0 part 
     259:2    0 465.5G  0 part /run/media/uname/79edeb60-fb3d-4569-b1d5-c385f2658b09
│    259:3    0 232.9G  0 disk 
│    259:4    0   300M  0 part /boot
     259:5    0 232.6G  0 part /home

Both of them are running Arch based distros, both were installed with the erase disk option in Calamares. Both are bootable from bios, and both have their own Grub.

What I would like, is to have the option to boot from either disk via one Grub. I have tried the steps listed in the discovery article, as well as the Archwiki.

As of now, os-prober does not seem to discover the other drives’ OS. How can I troubleshoot that?

Is the other OS also using BTRFS?
I remember having a similar issue setting up a multiboot system using BTRFS.
The regular os-prober seemed not being able to discover the other OS:es.
It was pointed out to me by @manuel to use one modified by Manjaro back then and that one worked.


Yes it is indeed running BTRFS, and installing the modified version of os-prober worked flawlessly. Thank you!

1 Like

You might need to set os-prober to be ignored for future updates and then check from time to time to see when Manjaro’s get updated and do it manually.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.