Triple boot endeavouros, windows 11 and fedora using endeavouros grub menu

I installed fedora workstation 39 (since I want to try gnome with wayland), a few weeks ago. I have tried to edit the endeaouros grub menu to be able to boot windows 11, endevouros and fedora. After weeks of searching for answers (including arch forum), I finally made it happen.
The solution was add the following to the /etc/grub.d/40_custom file:

menuentry “Fedora 39” {
insmod fat
set root=(hd0,gpt5)
chainloader (${root})/EFI/fedora/shimx64.efi
boot
}

then update grub with “sudo grub-mkconfig -o /boot/grub/grub.cfg” and then reboot.

Fedora placed its own efi files to dev/sda5; this is the reason why the line “set root=(hd0,gpt5)” worked. Just my guess.

You don’t have to install Fedora just to try a Gnome Wayland session, you can just select Xorg or Wayland session from the login screen before you login, if you have an Nvidia gpu you will have to do the following in order to have the Wayland session option show up.
https://wiki.archlinux.org/title/GDM#Wayland_and_the_proprietary_NVIDIA_driver

my endeavouros is KDE-x11. I was testing gnome-wayland/

Interesting. I’m surprised OS-Prober didn’t find it.

os-prober saw windows but not fedora