Touchpad questions after migration

I recently moved my laptop from Chakra to EndeavourOS with Plasma and am strongly considering the same move on my tower. I do have a few questions regarding the touchpad on my laptop, and those obviously won’t apply to the tower, but that’s where the Chakra screenshot below comes from - hence it being greyed out.

As you’ll see in those screenshots, or as you may be already aware of, Chakra’s much older version of Plasma (5.17.3, Frameworks version 5.64.0 and Qt version 5.13.2) has different touchpad settings from the much more recent version EOS comes with.

Specifically, I am looking to enable tap-to-click (greyed out in the EOS settings for reasons unknown to me), and to disable the touchpad when a mouse is plugged in (completely missing from EOS settings).

My question is: are these differences simply because of the much newer version, or is this a difference between what the Chakra and EOS teams “did to” Plasma? Is there a package I would need to install?

Any logs or info needed, just let me know and I’ll dig it up.

Chakra’s settings:

EOS’ settings:

Create:

cat /etc/X11/xorg.conf.d/30-touchpad.conf
Section "InputClass"
    Identifier "devname"
    Driver "libinput"
    option "Tapping" "on"
EndSection
1 Like

Nice, that indeed enabled the tap-to-click settings and ticked the boxes, and didn’t even require anything be reloaded for tapping to work.

Now let’s see if we can get it to disable the touchpad when it detects a mouse (and enable it when it detects the mouse being unplugged)…

Don’t use a mouse, so am no help there.

Anyone? I’d really like that touchpad to notice the presence or absence of a mouse…

As per the new thread on this, I had to undo the creation of /etc/X11/xorg.conf.d/30-touchpad.conf (or rather, I renamed it by suffixing ~ so it won’t be read anymore), as well as install good old xf86-input-synaptics to get the old settings back. It’s not installed on the desktop though, so why that has the old settings I still don’t understand, but at least it solved my problem. Marking this as solved as well, unfortunately I’ll have to mark my own post for that - unless of course @moderators have a better way for me to close this without taking undue credit.