Touchpad not working on acre aspire 5

I installed OS with wmi3 few months ago. Touchpad was working good. From this week my touch pad is not working any more. I googled and added 30-touchpad.conf file in /etc/X11/xorg.conf.d but its not working how to fix this?
my 30-touchpad.conf

Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "TappingButtonMap" "lmr"

xinput list output:

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech Wireless Keyboard PID:4023     	id=11	[slave  pointer  (2)]
⎜   ↳ Logitech Wireless Mouse                 	id=12	[slave  pointer  (2)]
⎜   ↳ SYNA7DB5:01 06CB:CEB1 Mouse             	id=13	[slave  pointer  (2)]
⎜   ↳ SYNA7DB5:01 06CB:CEB1 Touchpad          	id=14	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Acer Wireless Radio Control             	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Video Bus                               	id=8	[slave  keyboard (3)]
    ↳ Lid Switch                              	id=9	[slave  keyboard (3)]
    ↳ Power Button                            	id=10	[slave  keyboard (3)]
    ↳ Intel HID events                        	id=15	[slave  keyboard (3)]
    ↳ Intel HID 5 button array                	id=16	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=17	[slave  keyboard (3)]
    ↳ Acer WMI hotkeys                        	id=18	[slave  keyboard (3)]
    ↳ Logitech Wireless Keyboard PID:4023     	id=19	[slave  keyboard (3)]

First of all, run

xinput test 14

This will run a program to detect input events from your touchpad (device id = 14). After you run the command, move your finger around the touchpad to test it. You should see a bunch of text printed on the command line that looks like this every time you move your finger across the touch pad:

motion a[0]=1440 a[1]=665
motion a[1]=667
motion a[0]=1434 a[1]=672
motion a[0]=1423 a[1]=681
motion a[0]=1409 a[1]=689
motion a[0]=1389 a[1]=694
motion a[0]=1364 a[1]=698
motion a[0]=1342

xinput will print a[0] if horizontal motion is detected and a[1] for vertical movement. If there is not printed output, or if the movements across the touchpad doesn’t correspond to the printed outputs, then your touchpad might be faulty.

Have you seen:


There is no text printed in command line when i move my finger across the touch pad.

Yes, I tried all options in touchpad option but none of them work.

That means no input event was detected from the hardware.

Does it work in a live environment?

No, Its not working in live environment too.

I tried in ubuntu live environment. Seems like issue with hardware.

This is most likely the case. Not sure if it’s worth it to have the touchpad replaced. How old is the laptop?

I bought it 4 months ago.

From the brief search I made, it looks like there are major problems with this touchpad on linux :frowning:

What about the machine’s UEFI bios? There are graphical interfaces for UEFI bioses nowadays. Does the touchpad work there?

It’s not working.

Even in the UEFI bios? Then your touchpad is most likely faulty. You should have it replaced if it’s still under warranty.