TLS problems & freezes with latest nvidia driver

Hello,

Looking for some help, I`m currently facing two problems:
I cant connect to a few sites or repos, such as distroWatch, aur.archlinux.org (cant install anything from AUR), but I can ping them.

and…I can connect to them inside my VMs.
Tried reinstalling NetworkManager, Chromium said to check proxy but its already disabled…Not sure what to look


the second problem, using the nvidia-390xx driver, everything works fine, but, it doesnt support Vulcan so I need to run proton with OpenGL which is running a lot worst for a few titles.

While on the latest version (440x), it makes the whole system to hard freeze every few seconds, for like 5-15 seconds.

I`m on a laptop, here are the specs:
i7-4720HQ
GTX960M 2Gb
2x8Gb DDR3 1600Mhz
SSD 512Gb + 1Tb HDD

system fully upgraded

Anyone got any ideas? xd

Welcome @atetador, :hugs:

You should make separate threads for each of your problems.
For the first issue please return the output of inxi -Fxxxza --no-host

1 Like

Here you go

System: Kernel: 5.5.4-arch1-1 x86_64 bits: 64 compiler: gcc v: 9.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=37e1719b-a738-4c9e-89d0-fd35f3eef1a4 rw quiet loglevel=3
Desktop: KDE Plasma 5.18.1 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM Distro: EndeavourOS
Machine: Type: Laptop System: ASUSTeK product: G551JW v: 1.0 serial:
Mobo: ASUSTeK model: G551JW v: 1.0 serial: UEFI: American Megatrends v: G551JW.209 date: 03/04/2016
Battery: ID-1: BAT0 charge: 41.4 Wh condition: 41.8/47.5 Wh (88%) volts: 10.8/10.8 model: ASUSTeK ASUS Battery type: Li-ion
serial: status: Not charging
CPU: Topology: Quad Core model: Intel Core i7-4720HQ bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 3C (60)
stepping: 3 microcode: 27 L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41523
Speed: 2272 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 2272 2: 2336 3: 2552 4: 2786 5: 2546 6: 2437 7: 2829
8: 2298
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:0416
Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: ASUSTeK driver: nvidia v: 390.132 bus ID: 01:00.0
chip ID: 10de:139b
Display: x11 server: X.Org 1.20.7 driver: modesetting,nvidia compositor: kwin_x11 resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 960M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.132 direct render: Yes
Audio: Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio driver: snd_hda_intel v: kernel bus ID: 00:03.0
chip ID: 8086:0c0c
Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 00:1b.0 chip ID: 8086:8c20
Sound Server: ALSA v: k5.5.4-arch1-1
Network: Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: e000 bus ID: 04:00.0 chip ID: 8086:08b1
IF: wlan0 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: d000
bus ID: 05:00.1 chip ID: 10ec:8168
IF: enp5s0f1 state: down mac:
Drives: Local Storage: total: 1.38 TiB used: 922.35 GiB (65.5%)
ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541010A9E680 size: 931.51 GiB block size: physical: 4096 B
logical: 512 B speed: 3.0 Gb/s rotation: 5400 rpm serial: rev: A560 scheme: GPT
ID-2: /dev/sdb vendor: Zheino model: CHN 25SATAC3 512 size: 476.94 GiB block size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s serial: rev: 7A0 scheme: GPT
Partition: ID-1: / raw size: 69.44 GiB size: 67.85 GiB (97.71%) used: 14.92 GiB (22.0%) fs: ext4 dev: /dev/sdb2
Sensors: System Temperatures: cpu: 70.0 C mobo: N/A gpu: nvidia temp: 64 C
Fan Speeds (RPM): cpu: 2600
Info: Processes: 263 Uptime: 1h 05m Memory: 15.10 GiB used: 3.90 GiB (25.8%) Init: systemd v: 244 Compilers: gcc: 9.2.1
clang: 9.0.1 Shell: bash v: 5.0.16 running in: yakuake inxi: 3.0.37

When is the last time this laptop hardware was maintained (cleaned) ?

1 Like

Hello @atetador
Your Nvidia GTX960M should be using the 440.xx series drivers. You may have an issue with having the 390.xx drivers installed so you should remove all nvidia and install it properly. Have you tried using the welcome screen and just updating the mirrors?

Edit: Temps seems high also. You should be able to use the installer to install nvidia-dkms and bumblebee
You can run the installer test.

nvidia-installer-dkms -t

If there are no errors you can install the drivers with

sudo nvidia-installer-dkms

sudo systemctl reboot

You could also install bumblebee so add -b to the test and then also to the install. Example:
Test:
nvidia-installer-dkms -b -t

Install:
sudo nvidia-installer-dkms -b

Here is the info:

I runned the command just after closing a game xD

I cleaned and applied fresh MX4 on it a few months ago


I monitor temperatures all the time with an widget on my top bar.

I did follow that guide after I clean install, had problems… Then I went for the 390x drivers.

Have you looked at this site regarding vulkan.

Yes, thou, I`m not sure if that Max API version makes a lot of difference, or if its to blame for the freezes.

Eighter way, I cant try other versions that are on AUR cause I cant use it due to the first problem

Is it only the Arch Aur site you cannot connect to? Are you able to connect to all other https sites. The handshake error can be from too slow internet, being behind proxy, ISP issue, bad security certificates to browser issues etc. Have you tried other https sites, try another browser etc. That is all i can suggest until you can pinpoint the cause.

protondb, distrowatch, wiki.archlinux.org

some http some https

They work inside my VMs, tried inside a Manjaro, Solus and a Windows VM…They all connect.
Tried Chromium and Firefox, cant install chrome without AUR, which I cant connect rn.

I got 20mb/s down and up.
Proxy is disabled.

If I boot up on a liveUSB, I can connect normaly as well.

Can you ping them?

1 Like

YES! and I have no idea why

also, I just tried to connect to distrowatch after searching it on google and clicking on the result link and it connected and it loaded the page…but it doesnt stop loading

and it doesnt work for the other pages…And it only worked like 3 times, and its not loading anymore

You said you tried reinstalling network manager? Have you checked the /etc/resolv.conf file that is created by network manager. Maybe it isn’t correct for some unknown reason.

Edit : What is the output.

cat /etc/resolv.conf

It should contain your internal network address and your lan

image

My file only shows 2 ip addresses. One is my internal private address and the other is my connection to the LAN which is my service provider. Are you able to ping those ip addresses?
Edit: I know that 8.8.8.8 is Google
The other two i think are also Google IP version 6 maybe
138.185.128.2 must be your LAN

See if you can ping them and you could run:

whois 138.185.128.2

@atetador
I am unable to ping the IP version 6 addresses. Maybe you could just try commenting out those with # and save the file and see if it makes any difference as you can always change it back later. Both of those are Google.

You can use:
sudo nano /etc/resolv.conf

Then just comment out the two ip version 6 addresses in front of nameserver with #
Then save the file with ctrl x

This is just a test to see if that is the problem.

1 Like

Tried the changes to resolv.conf and no luck eighter xd

For now, I`m back to manjaro till I can get it working, going to install Endevour on a VM and see if I can replicate the problem, or make a dual boot with manjaro.

First time something like this happens to me, but seen a lot of topics about similar problems without solution on several foruns.

Thanks for the help guys