[Tip] Enable Magic SysRq Key (REISUB)

Did you remember the ALT key too? It is all in there…

1 Like

Were you holding Alt the whole time?

1 Like

Yep.
Maybe something else is intercepting it?

doing journalctl -xe I get:
Oct 06 22:42:04 onyx-laptop kernel: Emergency Sync complete
Oct 06 22:42:05 onyx-laptop kernel: sysrq: This sysrq operation is disabled.
Oct 06 22:42:06 onyx-laptop kernel: sysrq: This sysrq operation is disabled.

Nothing is intercepting it, it is the PrtSc key. It seems that it is disabled.

Did you enable it by creating that file, as the OP suggests? Check with

cat /etc/sysctl.d/99-reisub.conf

It should say

kernel.sysrq=1

Did you reboot after creating that file, as the OP suggests?

If yes, to both questions and it still does not work, look into the BIOS setup, if there is an option to enable it.

If nothing works, try asking about it on some official ASUS support place.

2 Likes

Thanks! I just tried this on one of my installs and it works perfectly. :wink:

3 Likes

I used this for the first time today. Works great. Thanks for the tip. :smiley: :beers:

2 Likes

I tried it a few times when system froze trying to install on vbox.

1 Like

My exact use case as well. I ended up installing things via qemu (after some research/learning on getting it all working).

I have done the same but virt-manager isn’t my favorite. I just don’t understand what’s up with vbox as i have no issue installing any EndeavourOS on it.

1 Like

Thanks for sharing this. I learned two things:

  • REISUB itself,
  • issuing a forkbomb :(){ :|:& };: to test it

Christoph

4 Likes