Timeshift problem

Good evening friends,

A small problem.

I installed timeshift for autobackup (daily) using the same parameters that have previously worked for me on the same hardware using manjaro (using the gui).

Unfortunately, despite the same setup, the automatic backups are not working. Manually, the backups work fine both from the gui and command line (i.e. sudo timeshift --create), so i think the config is good.

I wonder if there is a missing cron-like service on endeavour versus manjaro?

Kind regards to the great community!

OS: EndeavourOS Linux x86_64
:+sssssssssso/. Host: HP Z440 Workstation -/ossssssssssssso/. Kernel: 5.8.10-arch1-1
-/+sssssssssssssssso+: Uptime: 1 day, 12 hours, 46 mins
-:/+sssssssssssssssssso+/. Packages: 1376 (pacman) .://osssssssssssssssssssso+± Shell: bash 5.0.18
.://+ssssssssssssssssssssssso++: Resolution: 1920x1080, 1920x1080
.:///ossssssssssssssssssssssssso++: DE: Plasma 5.19.5
:////ssssssssssssssssssssssssssso+++. WM: KWin -////+ssssssssssssssssssssssssssso+++± WM Theme: Aritim-Dark
..-+oosssssssssssssssssssssssso+++++/ Theme: Aritim-Dark [Plasma], Breeze-Dark [GTK2],
./++++++++++++++++++++++++++++++/:. Icons: oxygen-icons-4.6.2 [Plasma], oxygen-icons-
`:::::::::::::::::::::::::------`` Terminal: konsole
CPU: Intel Xeon E5-1620 v3 (8) @ 3.600GHz
GPU: NVIDIA Quadro K2200
Memory: 3563MiB / 32029MiB

Make sure that the package cronie is installed and cronie.service is enabled and running.

just installed it - hopefully this works - thanks!

Cronie is the cron-like service as mentioned above - and it is not installed as a standard item because it may very well not be needed these days… as a systemd-timer will do most if not all things it might be useful for…

2 Likes

Enable and start the service as well:

sudo systemctl enable --now cronie.service

1 Like

This should fix your issue. If it doesn’t please check out the wiki here. This SHOULD fix your issue. If not, please post up again here. I’m sure we can figure it out.

** FYI - A while back I had a pretty severe issue with Timeshift hanging indefinitely while running dchcp service. After removing/disabling it, everything went away. I don’t know if it’s still an issue. But, just a heads up in case it does.

2 Likes

it worked!

thanks kindly once again.

interesting that the timeshift program would not recognize that it needs cronie.service

hope this helps others as well.

1 Like

Welcome to Arch based. You own your computer. It’s up to you.

4 Likes

Is it possible to get Timeshift to run with systemd-timer instead of cronjob?

Yes, but you will have to write your own timer which runs

timeshift --create
2 Likes

ty for the lesson!