TimeShift Not Taking Scheduled Snapshots

I have just reinstalled my beloved EndeavourOS, KDE, all defaults.
To be on the safe side, I installed and configured TimeShift to take hourly, daily and boot snapshots.

It has been a few hours now, and rebooted a few times, the only snapshot is the one I manually did after configuring.

What to do to get it to take the scheduled snapshots as configured?

[limo@EOS ~]$ inxi -Fxz
System:
  Kernel: 6.6.35-2-lts arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
  Desktop: KDE Plasma v: 6.1.1 Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Convertible System: HP product: HP Spectre x360 Convertible 13-ae0xx
    v: N/A serial: <superuser required>
  Mobo: HP model: 83B9 v: 56.50 serial: <superuser required> UEFI: AMI
    v: F.36 date: 03/19/2022
Battery:
  ID-1: BAT0 charge: 49.4 Wh (100.0%) condition: 49.4/49.4 Wh (100.0%)
    volts: 12.9 min: 11.6 model: HP Primary status: full
  Device-1: hid-0018:04F3:2597.0001-battery model: ELAN2514:00 04F3:2597
    charge: N/A status: N/A
CPU:
  Info: quad core model: Intel Core i7-8550U bits: 64 type: MT MCP
    arch: Coffee Lake rev: A cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 550 high: 800 min/max: 400/4000 cores: 1: 800 2: 400
    3: 400 4: 800 5: 400 6: 800 7: 400 8: 400 bogomips: 32012
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
    v: kernel arch: Gen-9.5 bus-ID: 00:02.0
  Device-2: Cheng Uei Precision Industry (Foxlink) HP Wide Vision FHD Camera
    driver: uvcvideo type: USB bus-ID: 1-5:3
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: modesetting dri: iris gpu: i915
    resolution: 1536x864
  API: EGL v: 1.5 drivers: iris,swrast platforms:
    active: wayland,x11,surfaceless,device inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.1.2-arch1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 620 (KBL
    GT2)
  API: Vulkan Message: No Vulkan data available.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  API: ALSA v: k6.6.35-2-lts status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active
Network:
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
    bus-ID: 02:00.0
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    bus-ID: 1-7:4
  Report: btmgmt ID: hci0 rfk-id: 4 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
Drives:
  Local Storage: total: 238.47 GiB used: 23.47 GiB (9.8%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-000H1
    size: 238.47 GiB temp: 34.9 C
Partition:
  ID-1: / size: 232.68 GiB used: 22.52 GiB (9.7%) fs: ext4 dev: /dev/nvme0n1p2
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 44.0 C pch: 41.5 C mobo: N/A
  Fan Speeds (rpm): cpu: 0 fan-2: 0
Info:
  Memory: total: 8 GiB note: est. available: 7.51 GiB used: 3.9 GiB (51.9%)
  Processes: 226 Uptime: 2h 43m Init: systemd
  Packages: 1044 Compilers: gcc: 14.1.1 Shell: Bash v: 5.2.26 inxi: 3.3.35
[limo@EOS ~]$ 

Did you install and enable cron?
https://wiki.archlinux.org/title/cron

Nop!
I just installed as I mentioned and simply followed defaults during installation.
I am sorry to say, I looked at the link you sent, it seems so techie for me.
I will appreciate a few commands to install, enable and configure it.

You are running an Arch-based distribution, being able to read and use the Archwiki should become second nature to you, but here you go.

sudo pacman -S cronie
sudo systemctl enable cronie.service --now
2 Likes

I fully agree with you, and I try most of the time to do this and try new things, and break my system(s) all the time.
But sometimes, a few things I don’t like to take the risk if I feel it is so serious and may break the system, like playing with bootloader, filesystem (though at some time I previously converted from EXT4 to BTRFS, and from Grub to systemd-boot, but sometimes I feel like shying away from taking the risk.

I really appreciate your support.
This is the beauty of this forum and community to add to the beauty of EndeavourOS.

UPDATE:
I did the commands, rebooted, still no new snapshots.

My humble understanding that TimeShift waits a little before taking a boot snapshot. Am I right?

I will wait and see.

2 Likes

Good to know! :slight_smile:

Yes it is but I still do like to remind people who run an Arch-based distributions that their goal should be working towards being able to do most things independently and of course the community can help help in that process of guiding people there by answering things new users don’t know or understand yet :enos: :enos_flag: :smiley:

3 Likes

Again I agree with you fully.
I am that guy who tries his best to learn all the time. And I have done so many stupid things, under EndeavourOS, or all the other distros I have been distrohopping like crazy,

But sometimes I prefer to ask the experts if it is something that can be “dangerous” to my system.

Thank you again for your support and guidance.

1 Like

That’s always to best thing to do if you are unsure of something.

Glad to have helped out!

1 Like

Now, after rebooting, I am “Up: 11m” (from inxi)
I still don’t have a boot snapshot though I selected it.
I still have to wait for like 23 minutes to reach the 1 hour!

I did the commands and rebooted.
Am I missing something?

Will be interesting to see what happens.

It might be this because when I check here, it says.
* **GRUB2** - Bootloader must be GRUB2. GRUB legacy and other bootloaders are not supported.

So maybe because you are not using Grub2 it doesn’t know how to detect that you booted? I haven’t used Timeshift in a long time and I’m not using Arch right now, so I can’t test it out for you, I would have to install a vm for that.

Another option you could also still have a look at for snapshots is btrfs-assistent.

It’s maintained by @dalto and has less requirements/restrictions than Timeshift and there is an AUR package.

I should have got a boot snapshot!

That was like a year ago when Grub broke.

You can see in other threads I have already tried BTRFS and even installed and used Recoll for file content indexing as Baloo does not play well with BTRFS.

I am always tempted to be on BTRFS again as I did before.

I am just worried of Grub or Grub2 that it might break and I end up with unbootable system.

Snapper was amazing and BTRFS Assistant was great, thanks to @dalto

I will see how it goes now
I wonder if Grub2 still breaks with updates

UPDATE:
I gues it is working, I found one boot snapshot.
I will wait more time and see how it does.

1 Like

Yeah I can understand why you switched to systemd-boot.

Will be interesting to see what happens.

1 Like

Just to update you @Cphusion
I just checked and I see I have hourly snapshots.

Thank you very much for your kind support.

1 Like

Do boot snapshots work too now? Besides the one you have in that screenshot, I don’t know if you have booted multiple times?

I have only one boot snapshot, it is in the photo above. It is labeled as you see as hourly, daily and boot!
Maybe I didn’t leave it enough time between reboots.

But anyway, having hourly snapshots is OK with me.
Thank you very much @Cphusion

Further update for you @Cphusion as I owe you.
I noticed I had a few boot snapshots, but they were not boot only, they were both boot and hourly. I wonder if TimeShift is smart to delay the boot snapshot to be with the hourly snapshot?
I noticed one of the snapshot was at 16:53, that is 7 minutes earlier and it was labled H and B.

Anyway it is working. Thanks to you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.