Timeshift doesn't create automatically

I have just switched from Manjaro to EnOS and I have noticed that timeshift has a problem with the creation in the background. Is there something special that I need to do explicitly to make this work on EnOS?

Kernel: x86_64 Linux 5.14.16-arch1-1
Shell: bash 5.1.8
DE: KDE 5.87.0 / Plasma 5.23.2
WM: KWin
CPU: AMD Ryzen 9 4900HS with Radeon Graphics @ 16x 3GHz
GPU: NVIDIA GeForce RTX 2060 with Max-Q Design

Are you sure cronie is working properly? This is a prerequisite.

Status: systemctl status cronie.service

if not :

sudo systemctl enable cronie.service

sudo systemctl start cronie.service

2 Likes

Cronie wasn’t working properly. So I have followed the steps, and now timeshift should backup on bootup. But I get an error message window:

Admin Acess Required to backup and restore system files. Please re-run the application as admin (using ‘sudo’ or ‘su’).

Here is the Cronie output:

● cronie.service - Periodic Command Scheduler
     Loaded: loaded (/usr/lib/systemd/system/cronie.service; enabled; vendor preset: disabled)
     Active: active (running) since Sun 2021-11-07 23:02:32 CST; 46s ago
   Main PID: 478 (crond)
      Tasks: 4 (limit: 18480)
     Memory: 1.7M
        CPU: 6ms
     CGroup: /system.slice/cronie.service
             ├─478 /usr/bin/crond -n
             ├─481 /usr/bin/CROND -n
             ├─482 /bin/bash -c "sleep 10m && timeshift --create --scripted --tags B"
             └─484 sleep 10m

Nov 07 23:02:32 endevouros systemd[1]: Started Periodic Command Scheduler.
Nov 07 23:02:32 endevouros crond[478]: (CRON) STARTUP (1.5.7)
Nov 07 23:02:32 endevouros crond[478]: (CRON) INFO (Syslog will be used instead of sendmail.)
Nov 07 23:02:32 endevouros crond[478]: (CRON) INFO (RANDOM_DELAY will be scaled with factor 28% if used.)
Nov 07 23:02:32 endevouros crond[478]: (CRON) INFO (running with inotify support)
Nov 07 23:02:32 endevouros CROND[482]: (root) CMD (sleep 10m && timeshift --create --scripted --tags B)

Thanks.

Delete all existing backups, then Timeshift should automatically create the first backup on the hour. What it has to do with the Bachup after system start, I can not help, sorry.

I don’t think cronie is setup by default in EOS as many folks don’t use it. Likely you just never had set it up as opposed to it not working properly.

3 Likes

Thanks for clarification. Any idea about the boot error when I set to timeshift after boot?

Admin Acess Required to backup and restore system files. Please re-run the application as admin (using ‘sudo’ or ‘su’).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.