Timeshift browsing problem

New EOS user here.
I want to use timeshift(-gtk) for making incremental backups. Timeshift require sudo to run which is ok. I made my first full backup to a second ext4 partition. But here is the problem. After doing the backup, I cannot browse the backup set. This is what I see in the console from where timeshift is started

**[anders@archie ~]$ sudo timeshift-gtk **
**[sudo] password for anders: **
App config loaded: /etc/timeshift/timeshift.json
Mounted ‘/dev/sdb1’ at ‘/run/timeshift/2999/backup’
Running Dolphin with sudo is not supported as it can cause bugs and expose you to security vulnerabilities. Instead, install the kio-admin package from your distro and use it to manage root-owned locations by right-clicking on them and selecting “Open as Administrator”.

kio-admin is installed but I still get this message. And right-clicking on the backup set in timeshift does not include an “Open as administrator”.

Is this a known issue?

Welcome to the forum!

Keep in mind that Timeshift is not a backup tool, it’s a system snapshot tool. You should not include your home directory or any of your user data in the snapshots, because that can lead to data loss when a snapshot is restored.

You should use something else for backup of user data.

Regarding your use of Dolphin, it is indeed not meant to be used with sudo. In fact, no GUI application should ever be run with sudo. There are several reasons why this is so, the two most often mentioned are: 1) corruption of the permissions of the config files in the user’s home directory, which can cause issues that are notoriously difficult to troubleshoot, 2) GUI libraries and widget toolkits contain millions of lines of code that has not been intended to run as root and has not been tested with sudo. Running them without root privileges provides a layer of safety for most of the vulnerabilities in the code.

The best way to “browse” directories in which your user does not have the permission to read is to use a shell in a terminal, or some TUI file manager.

1 Like

I get it, but Timeshift has saved my a*s a number of times before on plain Arch, regardless if its considered a backup or snapshot tool. On plain Arch, the snapshot browser works as expected.

So I guess timeshift is not very useful on EOS then? What alternative do you recommend? I do have a NAS on my network so maybe I should just rsync to that one instead. However, it will not offer system restores in the same way as timeshift does.

Something being used in a way its not meant to be just because it worked in the past doesn’t mean its the correct way to do something.

Snap shots are supposed to be a quick way to restore the OS and not really a backup / recovery tool for your personal data. Snapshots are a way for administrators to quickly get a machine back up an running for a corporation that is time critical not like your home system that isn’t critical to anyone except you. Not that you can’t use it at home as many do just need to keep in mind why it exist in the first place.

A lot of people use it here so I don’t see where you come to this conclusion.

This is where you should be storing your personal backups (/home)

yeah its the trade off you have for having up to date backup as opposed to a moment in time back up.

I just tried it in a vm running EndeavourOS, when I run “sudo timeshift-gtk” in a terminal I get the same as you but when I just open timeshift from the menu, it will open and then ask you for your sudo password. Then select a snapshot and then click on browse dolphin opens like you expect, it does display a message about it not being a good idea to do that as root but you can still do your thing. Also you don’t need to use the terminal to open an application with sudo, if a gui application needs it, it will probably ask for it.

1 Like

It’s exactly the same as on Arch. Pretty much all of the software on EndeavourOS comes from the official Arch repos.

Personally, I don’t think Timeshift is particularly useful on any distro. I used to use it on Manjaro, and on EndeavourOS when I had an ancient NoVidea graphics card that required drivers from the AUR, which would break every time the kernel got updated. It was pretty convenient then, but that was years ago, and I haven’t used it since. To me, in the current year, Timeshift seems like total waste of storage, because there is nothing in the system that is worth backing up. It is user data that is irreplaceable, not the system.

Usually, whenever there is a “serious” problem, like updates making the system unbootable (which on EndeavourOS happens about once a year, but it only affects a small subset of users, so actually it happens much rarer than that for any specific user), the step-by-step instructions on how to fix it get published here on the forum within couple of hours. And, usually, it’s something very easy to do, like boot up a live ISO image, chroot and execute a command. Keeping hundreds of gigabytes of system snapshots just so I would avoid this little inconvenience is not something I personally find worthwhile.

1 Like

This is probably not due to Dolphin itself, because I (Plasma 5.27.10) can browse the snapshots from Timeshift without any problems:

This is not the problem. The issue that I cant restore from within Timeshift GUI. Worked fine from vanilla Arch (using i3 as WM, not KDE).

You mentioned dolphin that’s why everyone was assuming you are using KDE Plasma. It works see screenshot.

The only difference is that with what you do is you run “sudo timeshift-gtk” from the terminal. Just open Timeshift from the menu and you can then just browse/restore the files in your snapshots. When you click the browse button the dolphin filemanager shows up. What more do you expect to happen?

My bad. I was using i3 in my previous Arch install. Now I am in KDE on EOS. :slight_smile:

You are right, it works fine when started from the Application menu. Thanks!

1 Like

I don’t use KDE Plasma, but just from testing it out in my vm with Plasma. I see that the package “kio-admin” is used in combination with Dolphin. When you have the package installed, open Dolphin and then when you right click on a location you get the option “Open as Administrator” . When you open Timeshift from the terminal it doesn’t like that and gives you a warning about that, I would think because Timeshift opens Dolphin as root and I would think Dolphin as some sort of security built into it to not allow that by default. However when you open Timeshift through the menu I think polkit is used which then asks you for your sudo password and it then allows Timeshift to open Dolphin to browse your files, gives you a warning but still allows it.

Apps such as timeshift can really only be used safely via text commands in the terminal. This just so happens also to be the arch way of doing things!

Syntax:

  timeshift --check
  timeshift --create [OPTIONS]
  timeshift --restore [OPTIONS]
  timeshift --delete-[all] [OPTIONS]
  timeshift --list-{snapshots|devices} [OPTIONS]

For example:

To create a new snapshot: sudo timeshift --create

To list snapshots: sudo timeshift --list

More on how to use timeshift via the terminal:

timeshift --help

1 Like