Tigervnc blocky/ghosting issues

Since a couple of days I am having issues with tigervnc which seems to have some kind of compression issue causing the remote view to be blocky and have some ghosting. It appears to be linked only to tigervnc as I can connect to the same machine with remmina and all appears normal, however tigervnc manages different resolutions better than remmina so I’d like to get tigervnc working normally again if possible. I’ve tried adjusting the compresion settings in tigervnc but this makes little to no diffference to the problem. I have rebooted both the local and remote machines and tried removing and reinstalling tigervnc without any improvemnt. I have an up to date and lts kernel installed and tried restarting with bot, no difference. I even got desperate and tried chainging the remote desktop background colour to a rather bright pink. I’m not sure exactly when this might have started as I’m only just back from 3 weeks holiday but before it was working perfectly. I even tried rolling back to the previous version of tigervnc which seems to have been updated around 10/08/2023 but this didn’t work either so I guess it might be linked to another change or a dependency? Thanks in advance for any ideas you might have.

Launch it from a terminal and see if there are errors reported.

Nothing obvious as far as I can tell…

[xxxx@xxxxx~]$ vncviewer 

TigerVNC Viewer v1.13.1
Built on: 2023-08-10 01:23
Copyright (C) 1999-2022 TigerVNC Team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.

Wed Aug 30 17:24:09 2023
 DecodeManager: Detected 8 CPU core(s)
 DecodeManager: Creating 4 decoder thread(s)
 CConn:       Connected to host xxxxxxxxx port 5901
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8
 CConnection: Choosing security type VeNCrypt(19)
 CVeNCrypt:   Choosing security type TLSVnc (258)

Wed Aug 30 17:24:15 2023
 DesktopWindow: Reducing window size to fit on current monitor
 CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888
 CConnection: Enabling continuous updates



As a bit of a follow up I restarted gnome using xorg and the problems with tigervnc are gone. So it would appear to be something to do with wayland perhaps…but no idea about how to resolve it still.