Thunderbolt usb-c doesn't detect monitor

Hello community, how are you doing?
I’m writing because I’m having problems with my external monitor connected by thunderbolt c.
I am using a usb c - hdmi adapter ANKER with which I connect a second external monitor Samsung.
I have been using it correctly for a week but since this morning it does not detect the monitor.

Any command output to provide further information required I can share.
Thank you very much!

First Welcome to the community

Second lets get you some info that will help others be able to help you. The information you give is extremely minimal and uninformative.

What is the GPU you are using?
Have you viewed log files to see if there is a driver failer? do you know how to access logs?
have you actually tried another cable? tried the cable on another device? what actions have you taken to rule things out?

Thank you for your message! I share with you the information of my video board.

00:02.0 VGA compatible controller: Intel Corporation CometLake-U GT2 [UHD Graphics] (rev 02) (prog-if 00 [VGA controller])
        DeviceName: To Be Filled by O.E.M.
        Subsystem: Lenovo CometLake-U GT2 [UHD Graphics]
        Flags: bus master, fast devsel, latency 0, IRQ 145
        Memory at b0000000 (64-bit, non-prefetchable) [size=16M]
        Memory at a0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 2000 [size=64]
        Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
        Capabilities: [40] Vendor Specific Information: Len=0c <?>
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [100] Process Address Space ID (PASID)
        Capabilities: [200] Address Translation Service (ATS)
        Capabilities: [300] Page Request Interface (PRI)
        Kernel driver in use: i915
        Kernel modules: i915

Where can I check the logs? I checked with dmesg but found nothing.

at command prompt type

I didn’t know that command. Thanks! But I didn’t find any error or warning