Thunar crashes since today

You are able to edit previous posts rather than posting several times in succession. This is a forum, not a chat room. :wink:

1 Like

i am new to this
this is my first time

You’ve been on the forum for nearly a month… you’re hardly “new” now.

i mean i am new to past som thing of my erorr

but i find my problem gtk3 was update to new one
so i downgrade gtk3
and now it work again :yum:
it was not linux kernel problem

4 Likes

Can reproduce, mounting my NTFS disk crashes thunar. (But after that I can open it and go to it, because it’s already been mounted).

Rebuilding thunar against the new version of gtk3 did indeed resolve the problem for me.

4 Likes

Nice. I’ve added that to the bug report, hopefully it will be picked up soon.

6 Likes

How does one you rebuild thunar against the new version of gtk3?

At aa guess - you collect the package from the pacman cache, take it apart, edit the PKGBUILD to call the new version of GTK, and makepkg -si. I’m sure someone will correct me if I’m wrong :grin:

Strangely, though, none of my builds SO FAR have had this problem, thunar continues to function just fine despite the updates. I’m on all AMD though - if that might make a difference?

1 Like

Pkgbuild from archlinux.ort lol

I am having the same issue as in the opening post. It turns out, Thunar crashes whenever it opens a directory with a .ods file (I have not tested any other file type, but it may have to do with file thumbnails?)

Running XFCE and this problem only started after today’s update. PCManFM works fine.

This is not happening for me.

Not happening here either. All updates complete and Thunar working normally.

As I mentioned - all updates applied on several builds and no problems discovered with Thunar. I even went looking for .ods files (found 1!) and it was fine too…

Very strange…

Arch reports that the issue has been fixed with gtk3 1:3.24.28-4:

https://bugs.archlinux.org/task/70416

2 Likes

Yes, it is very strange.

In my case, I didn’t have to do anything in Thunar to make it crash. I simply opened Thunar and it crashed on its own within seconds. Opening Thunar in a terminal gave me the error message mentioned by @lucky58 in the OP.

After I rebuilt Thunar and reinstalled, Thunar worked again for quite a while, but then the problem returned.

Also very strange: I had the problem in one Arch install but not in another.

Anyway, gtk3 1:3.24.28-4 is said to fix the problem, and we should see it in the repos soon. In the meantime, downgrading gtk3 fixes the problem.

Why is this not affecting everybody?

I have

gtk3 1:3.24.28-3
thunar 4.16.6-1

And it is working just fine. Including directories with .ods files.

Is this theme related? I am using Materia theme.

I have the same versions as you, also working perfectly.

    OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: GA-78LMT-USB3 R2 
             `-/ossssssssssssso/.          Kernel: 5.11.13-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 15 hours, 55 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 1061 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.1.4 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080 
    .:///ossssssssssssssssssssssssso++:    DE: Xfce 4.16 
  `:////ssssssssssssssssssssssssssso+++.   WM: Xfwm4 
`-////+ssssssssssssssssssssssssssso++++-   WM Theme: Default 
 `..-+oosssssssssssssssssssssssso+++++/`   Theme: Arc-Dark [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Icons: Papirus-Dark [GTK2/3] 
  `:::::::::::::::::::::::::------``       Terminal: xfce4-terminal 
                                           Terminal Font: Monospace 12 
                                           CPU: AMD FX-8350 (8) @ 4.000GHz 
                                           GPU: NVIDIA GeForce GTX 1060 6GB 
                                           Memory: 1959MiB / 15988MiB 
Name            : gtk3
Version         : 1:3.24.28-3
Name            : thunar
Version         : 4.16.6-1

Not had any problems, but gtk3 was updated to 1:3.24.28-4 already - so the problem may be fixed now.

1 Like

I just had a crash while accessing a USB device. Downgrading to gtk3-1:3.24.28-2 has solved it.