Thinkpad T14 AMD and EOS

I’m about to pull the trigger on a Thinkpad T14 Gen 1 AMD to replace my really loud Acer Predator 17 desktop replacement laptop with a gtx1060 and an i7 6700HQ in it. The Acer has this really annoying buzzing noise like this thread here

So I’m going to get a Thinkpad T series as I hear they are well built and run linux well. I’m going to be using it for work so Python programming. I will also need 32gb of ram (16 onboard and another 16gb add on for dual channel) because I will be running Virtual machines and Docker containers for development.

My question for all Thinkpad T14 or other Thinkpad owners, will there be any hurdles on installing or getting EOS working on it? Any tips would be appreciated.

Also, on another note, how shall I dispose of this loud Acer machine?, The machine is working 100% but the sound is driving me insane

Just installing it. I think I was posting on the forum within 15 min of opening the box. T480s

If your other computer is junk, I drop things off at best buy for recycling.

Check Arch wiki for that model if there is any problems. If not you are golden

I would perform open heart surgery on that bad boy and if the result isnt satisfactory sell him on ebay.

Ah, Thanks for this.

It works without going through any hoops.

1 Like

I just wanted to add my data point. But I don’t know if this is due to EOS or not.

I’m not able to get 1000 Mbps speed on my ethernet. My driver is r8168 on EOS. I cannot figure out why this is happening. So, I’m stuck on 100 Mbps.

Also, the fingerprint scanner broke on some update. But I don’t use it, so didn’t look into it.

As mentioned above the archwiki contains a list of problems and the lenovo forums don’t look promising. I expected more from a Thinkpad machine to be honest.

Did you try the r8169 module instead?

I just got a Thinkbook 14" AMD 5500U and it is great. No issues with backlit keyboard. Everything works out of the box.

Edit: The Thinkpads are solid performers.

I remember following a thread somewhere in these forums and the suggestion was to try the r8169 module. So I did

sudo modprobe -r r8168
sudo modprobe -i r8169

But the issue persisted, so I reverted the changes and didn’t try anything after that.
I definitely verified that my router had 1000 Mbps enabled for the LAN port.
Maybe I missed something subtle. Will follow that thread again and try fixing it this weekend.

My machine is Thinkpad T14 AMD gen 1 4650U.

First I would try is to uninstall the r8168 entirely (I did even though it sometimes worked). It is my understanding that the r8169 module is in the kernel by default (after a reboot). YMMV of course (not my area of expertise - but a low-risk thing to try!)

I agree with @freebird54 to try uninstalling the r8168 package and it will use the r8169 kernel module. See if that makes any difference with it removed because if your system works on the r8169 you don’t need it.

This is incredibly late and I’m sorry about that. I hope this is helpful for anyone in the future.
Some weeks after my message, everything started working properly. I don’t know what I did or if I even did anything. I don’t remember updating my system before everything started working. I guess I’ll never find out what went wrong or what fixed it, but I’m happy now.
The Thinkpad T1 Amd gen 1 works pretty well with EOS otherwise. One general criticism about the laptop is that the exhaust is on the right side of the laptop where I keep my mouse. So, my hand gets bombarded with hot air, especially when a video is playing on any browser. Hardware video acceleration can usually mitigate this, but getting hardware video acceleration to work properly on browsers on linux (in general) is a whole other problem not related to EOS.