There's a new amdvlk package that breaks proton games

I have installed today amdvlk 2022.Q2.3-1, after that I couldn’t start any proton games, most of them complained about the hardware not being dx12 capable. Tried multiple proton variants. I use a ryzen 5700g.

I have restored the system with timeshift and the games start now. amdvlk was the only package related to vulkan in today’s update.

Here are the packages:

: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Package (5)            Old Version  New Version  Net Change

extra/amdvlk           2022.Q2.2-1  2022.Q2.3-1    3.15 MiB
core/e2fsprogs         1.46.5-3     1.46.5-4       0.00 MiB
multilib/lib32-amdvlk  2022.Q2.2-1  2022.Q2.3-1    3.45 MiB
extra/speex            1.2.0-3      1.2.1-1        0.00 MiB
extra/speexdsp         1.2.0-2      1.2.1-1        0.00 MiB

Total Installed Size:  122.28 MiB
Net Upgrade Size:        6.60 MiB

Did you reboot after installing amdvlk?

It’s not a bug it is a driver issue. Switch to vulkan-radeon it’s a better driver anyway.

2 Likes

hey, thanks for the reply, I did the install again and rebooted to make sure, it still doesn’t work. Tried some other game too with the AMD_VULKAN_ICD=RADV variable but that game complains about directx too.

well some games crash or don’t look right with vulkan-radeon, so I have both installed and use AMD_VULKAN_ICD=RADV when I need that driver.

Looks like this happened to others too https://github.com/GPUOpen-Drivers/AMDVLK/issues/278