The USB key I use to install EndeavourOS is not anymore recognized as bootable, once the installation is completed

I did it, but it only shows a generic Removable drive entry which does not boot from the USB key. (It actually boots EOS from my hard disk.)
Only once I flash again the ISO on the USB key, I can see a boot entry for the USB key, and boot from that.

Normally, no matter how old the ISO is, it should boot. In this case, it could be a mechanical issue with the connector from either the USB key or the port. But that is something for you to figure out by trying several times.

It happened with three different computers. On the same computer, it happened with different USB ports.

Have you tried different USB keys? I recently had to say goodbye to one that served me nine years of ISO writing/booting intensively.

I did that too. I bought a new one because the connector of the old one was slightly broken, but I get the same result with the new one.

Before we go further asking each micro step to each other could you describe what you did?
With this I mean, which method do you use to write the ISO, and if you tried to boot another distro on these computers?

You can check in Gparted if the usb drive still has a boot flag checked? If not it is not recognized as boot medium anymore.
How that could happen is the question though

Are you running multiple OS’s on your computer? Like EnOS plus Windoze, or OS-X? That could reset some bios functions regularly.

Also, like Brian suggested, I’d look deeper into the start-up options of Bios/UEFI of your system. - Perhaps, it can be updated from the vendor’s site, too?

I installed only EndeavourOS.
To select the USB key for the next boot, I enter in the UEFI settings to select the USB key as first boot entry, but there is not entry for the USB key, except a generic one that does not select the USB key. (In fact, it just boots from EndeavourOS I installed from the USB key.)

Did you look into a potential bios update yet? (For this, you would need to check your computer vendor’s website.)

Also, as Bryan suggested, did you try booting the usb with a different distro-iso yet?

To avoid issues, I have to create the installation USB key with Rufus, on a Windows machine; then, I can use the USB key more than once.

I cannot say why this happens, but I suspect the way the USB key is formatted could explain what happens.

not to rewarm this thread… but to mention… in cases you need to plug USB drive off the system and replug after power cycle to get it visible again. I have this randomly with usb sticks in general independend from what is written on them…

1 Like

My experience with such issues is to ensure the USB partition table is using GPT rather than MBR. This almost certainly will always be recognized by UEFI only motherboards. I’ve only seen USB Live boot issues on motherboards that don’t officially support legacy boot.

Rufus and Ventoy are the only two applications I know of that give you the option to choose GPT partition table.

usually … the ISO creation is done in hybrid-iso mode it is ready to be used as it is and what is recommended is to write the image without any changes to the usb pendrive.
Every change of the structure will make the ISO unstable :wink:

I have a motherboard that doesn’t support legacy boot, and I can only boot the EOS ISO if it’s in the GPT partition table via Ventoy. If it’s MBR, the USB is never recognized by the BIOS BOOT. Took me a long time to figure this out through troubleshooting and I came to the conclusion that if it’s UEFI only, this is what it takes.

ventoy is a bootloader already… kinda a chainloader that loads the ISO in later state… i bet you can boot ISO just fine if you use direct write methods like dd ?

I assure you I tried everything you can think of.

The partition table matters for some motherboards. It’s not just the EOS ISO. It’s the same for Arch, Debian, FreeBSD, slackware, gentoo, you name it. I used Fedora image writer, popsicle, dd, etc. All of them fail to detect the USB on boot. It simply doesn’t show it in the boot device options.

As soon as I make a Ventoy USB with GPT partition, voilà, Ventoy USB is detected and all ISOs load. I spoke to the manufacturer of my mobo (intel) and they told me legacy boot is not supported. That’s what led me to look deeper and find this solution.

can be that indeed, there are a lot of badly designed efi systems out there.
What i was mention was that the ISO itself can not be changed to hafe gpt nor msdos partition table, in case of ventoy you boot the ventoy bootloader and from there ventoy chanloading the ISO as it is or even using its own chanloader that uses grub to load the ISO… but the ISO is intact as it is you only copy it as it is to the ISO storage used by ventoy.

And the ISO is a hybrid ISO having both options to be autodetected and used by the firmware/Bios efi is following default standards to be booted properly on the ISO.
If the efi/firmware is wrongly detecting legacy boot also they say they do not support this… sounds a bit like they hide faulty design by that …

1 Like

more a workaround i think, but as long as it leads to be able to properly install EndeavourOS i am okay with it :wink:

1 Like

I see what you’re saying. It very well could be a BIOS firmware issue. I have been keeping an eye out for a newer version, but intel is pretty awful at supporting anything but windows, so I’m not holding my breath. Thank goodness for software like Ventoy for making it possible, otherwise I would have to dish out more money to buy a new system and I wouldn’t be able to use Linux in the meantime. :face_with_diagonal_mouth: