The installer USB only sometimes boots into the live environment

Hi guys,

Sorry if I’ve done this wrong lol. I rarely ever use forums and it’s my first post on this one.
I’m here because I’ve been having issues booting the EndeavourOS installer.
Usually I’d figure out stuff like this myself, but this is really weird.

It’s rather hard to explain what’s happening, but essentially the installer will graphically bug out at a specific point and never progress to the actual live environment.

Apologies in advance if this isn’t allowed, but here’s a Drive link since I can’t seem to upload a video directly:
The quality on Drive’s built in video player kinda sucks, if it’s really that big of a problem you could always download it.

It happens at pretty much the same spot every time, and it seems to be random when this occurs.
I have had a few times where it works. Iirc, these are only when the USB hasn’t been used yet after a reflash.
(Although I may be mistaken, I have been trying lots of different things so I may have lost track)

I’ve tried pretty much everything I can think of:

  • Reflashing the USB
  • Writing it in DD Image mode rather than ISO
  • Using a different USB port on my computer
  • Booting using BIOS rather than UEFI
  • Trying the NVIDIA boot option (despite not having a ‘latest card’)

It’s also worth noting that while I’m not very ‘good at Linux’ in general, I am especially new to Arch and Arch-based distros.
So I wouldn’t be surprised if the solution may be very simple.

Please advise, thanks.

1 Like

Welcome to the forum!

Have you tried redownloading the iso to make sure there is no corruption? What program did you use to prepare the live USB? Did you create the usb in UEFI? And finally switched off fast boot, do you still run windows?

That info might be useful. You don’t need generally to boot into Nvidia you can also use the nouveau driver, it should work. We don’t know which Nvidia hardware you have, that might be useful too to see if it’s compatible with newest Nvidia driver.

PS: sorry don’t watch the video because I don’t click on links from strangers in Google drive :wink: other infos would be more useful.

1 Like

Some hardware info at least about CPU/GPU would be helpful.


No problem:

CPU: Ryzen 7 3700X
GPU: GeForce RTX 2070
PSU: 650W


Yes, I’ve tried redownloading the ISO several times.
I’ve been using Rufus, but I did try Popsicle once with no luck.
Rufus specified I could boot the ISO image in either BIOS or UEFI, and that was the only option with the current settings.
I have disabled Secure Boot, but not Fast Boot. I’ll try it and let you know how it goes. Cheers!

EDIT: I have already sent my hardware info in response to someone else on this post. You should be able to see this.

Alright, I’ve disabled Fast Boot, it did not fix the issue. The issue persists at the same spot and in the same way.

try with ventoy
check also your UEFI motherboard options

I tried updating my BIOS, experimenting with settings and reverting them back to defaults when nothing worked.

After experimenting a bit with KDE Neon (which did the same) I discovered that Neon’s safe graphics boot option eliminates the error. Iirc, Endeavour doesn’t have such an option.

I will definitely try it with Ventoy, haven’t played around with that before.

Ok, I flashed it using Etcher, and after the ‘catalog’ message flashed up, a big chunk of the screen went black as shown in the video. But the lines never appeared and nothing messed up, and a split-second later everything returned to normal and it seems to have booted correctly…???

these boards have issues with the ethernet/wifi device if I remember right…
And the only workaround is to disable it in bios ?

I’m just using Ethernet, works fine…

so you disabled wifi in bios?

The mobo doesn’t have Wi-Fi.

what is reported on these boards is that if you disable etherent/wifi in bios it runs the ISO just fine… but yea no network in this case… you could use wifistick or USB thetering with a smartphone.

I’m going to try the ISO from the message marked as the solution on this post