Testing repos: systemd-249rc2-1 unable to boot

With the testing repos, systemd 249rc2-1 seems to be unable to boot.
I downgraded to previous systemd 248.3-2 and it works OK.

1 Like

Seems to be working alright on

this system
inxi -Fxxxz
System:    Kernel: 5.12.13-zen1-2-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: GNOME 40.2 tk: GTK 3.24.29 
           wm: gnome-shell dm: GDM 40.0 Distro: Arch Linux 
Machine:   Type: Laptop System: Dell product: XPS 13 9380 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 0KTDY6 v: A00 serial: <filter> UEFI: Dell v: 1.13.1 date: 03/25/2021 
Battery:   ID-1: BAT0 charge: 38.1 Wh (89.4%) condition: 42.6/52.0 Wh (81.9%) volts: 8.3 min: 7.6 
           model: LGC-LGC6.73 DELL H754V8C type: Li-ion serial: <filter> status: Discharging 
CPU:       Info: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Kaby Lake note: check rev: B cache: 
           L2: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31999 
           Speed: 700 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 700 2: 700 3: 742 4: 746 5: 800 6: 716 7: 800 8: 800 
Graphics:  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:3ea0 class-ID: 0300 
           Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:2 chip-ID: 0c45:6723 class-ID: 0e02 
           Display: wayland server: X.Org 1.21.1.1 compositor: gnome-shell driver: loaded: i915 
           note: n/a (using device driver) - try sudo/root resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.1.3 direct render: Yes 
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           chip-ID: 8086:9dc8 class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.13-zen1-2-zen running: yes 
           Sound Server-2: JACK v: 1.9.18 running: no 
           Sound Server-3: PulseAudio v: 14.99.2-1-g36fcf running: no 
           Sound Server-4: PipeWire v: 0.3.30 running: yes 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Rivet Networks Killer 1435 Wireless-AC 
           driver: ath10k_pci v: kernel port: efa0 bus-ID: 02:00.0 chip-ID: 168c:003e class-ID: 0280 
           IF: wlp2s0 state: up mac: <filter> 
Bluetooth: Device-1: Foxconn / Hon Hai type: USB driver: btusb v: 0.8 bus-ID: 1-7:3 chip-ID: 0489:e0a2 class-ID: e001 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 465.76 GiB used: 46.97 GiB (10.1%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 
           rotation: SSD serial: <filter> rev: 2B2QEXE7 scheme: GPT 
Partition: ID-1: / size: 50 GiB used: 14.04 GiB (28.1%) fs: btrfs dev: /dev/nvme0n1p5 
           ID-2: /boot/efi size: 126 MiB used: 546 KiB (0.4%) fs: vfat dev: /dev/nvme0n1p4 
           ID-3: /home size: 50 GiB used: 14.04 GiB (28.1%) fs: btrfs dev: /dev/nvme0n1p5 
           ID-4: /var/log size: 50 GiB used: 14.04 GiB (28.1%) fs: btrfs dev: /dev/nvme0n1p5 
Swap:      ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p7 
           ID-2: swap-2 type: zram size: 1024 MiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 32.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 fan-2: 0 
Info:      Processes: 273 Uptime: 15m wakeups: 437 Memory: 7.42 GiB used: 1.86 GiB (25.0%) Init: systemd v: 249 Compilers: 
           gcc: 11.1.0 Packages: 954 pacman: 943 flatpak: 11 Shell: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.03
systemd 249rc2-1

$ pacman -Qi systemd
Name : systemd
Version : 249rc2-1
Description : system and service manager
Architecture : x86_64
URL : https://www.github.com/systemd/systemd
Licenses : GPL2 LGPL2.1
Groups : None
Provides : nss-myhostname systemd-tools=249rc2 udev=249rc2
Depends On : acl libacl.so=1-64 bash cryptsetup libcryptsetup.so=12-64 dbus
iptables kbd kmod libkmod.so=2-64 hwids libcap libcap.so=2-64
libgcrypt libxcrypt libcrypt.so=2-64 systemd-libs libidn2 lz4 pam
libelf libseccomp libseccomp.so=2-64 util-linux libblkid.so=1-64
libmount.so=1-64 xz pcre2 audit libaudit.so=1-64 libp11-kit
libp11-kit.so=0-64 openssl
Optional Deps : libmicrohttpd: remote journald capabilities [installed]
quota-tools: kernel-level quota management
systemd-sysvcompat: symlink package to provide sysvinit binaries [installed]
polkit: allow administration as unprivileged user [installed]
curl: machinectl pull-tar and pull-raw [installed]
libfido2: unlocking LUKS2 volumes with FIDO2 token
tpm2-tss: unlocking LUKS2 volumes with TPM2
Required By : accountsservice base bluez-utils bolt colord cups cups-filters gdm
gnome-bluetooth gnome-desktop gnome-disk-utility gnome-logs
gnome-remote-desktop gnome-session gnome-settings-daemon
gnome-system-monitor libcolord libgdm libinput libpulse libwacom
mkinitcpio pcsclite phodav polkit rtkit systemd-sysvcompat upower
vte3 xdg-user-dirs
Optional For : None
Conflicts With : nss-myhostname systemd-tools udev
Replaces : nss-myhostname systemd-tools udev
Installed Size : 25.76 MiB
Packager : Christian Hesse arch@eworm.de
Build Date : Fri 25 Jun 2021 11:29:54 PM CEST
Install Date : Sat 26 Jun 2021 11:46:13 AM CEST
Install Reason : Installed as a dependency for another package
Install Script : Yes
Validated By : Signature

249rc2-1 also OK here.

Is there any log/output/journal entry that points to anything?

Working here also on Plasma.

Finally had some time to figure this out, or at least a workaround.
New systemd 249 seems to have changed how it interprets some stuff in /etc/fstab.

I used to have this line in /etc/fstab for a USB stick:

LABEL=XYZ  /XYZ ext4 defaults,nofail

and it worked without issue with older systemd 248.x.
But with systemd 249 it waited about 2 minutes for this USB stick before booting. The USB stick was not connected, and option nofail does not help in systemd 249, as it did with 248.

Now I changed the line to:

LABEL=XYZ  /XYZ ext4 defaults,nofail,x-systemd.device-timeout=1ms,x-systemd.automount

and the system works again as expected with systemd 249.

Maybe this is documented somewhere in systemd 249 …

3 Likes

As a side note, you shouldn’t need nofail with x-systemd.automount. systemd automounts are mounted on demand. They don’t block things.

1 Like

Thanks, I agree, will try that.

By the way, the reason revealed itself by simply removing the quiet kernel parameter. Obvious troubleshooting method in hindsight. :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.