Terminal Print out after complete_alias install

Hello,

I am using a code from this project https://github.com/cykerway/complete-alias which is used to autocomplete aliases with tab. It does work however, after its istal when opening anew terminal window i get a print out up top with the following

 complete: usage: complete [-abcdefgjksuv] [-pr] [-DEI] [-o option] [-A action] [-G globpat] [-W wordlist] [-F function] [-C command] [-X filterpat] [-P prefix] [-S suffix] [name ...]

I have checked the script , it is only a few lines but there is no echo statement that looks anything like this. How can I get rid of theis?

Thanks,

theleapingfrog

How did you integrate into your bash startup? That text is probably the error text from the complete command when it is run with bad parameters.

I have sourced it into .bash_completion. I have not put anything into the .bashrc about it.

Problem solved

In the .bash_complete you are suposed to source the script. I have my script in ~/Scripts/bash to source it in .bash_complete I had used . ~/Scripts/bash/complete_alias . I have changed it to source ~/Scripts/bash/complete_alias. That solved the issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.