Terminal not showing actual text

Yeah, just tried it again with your suggestion of the lts kernel and still no dice.

@timms5000 @Kaz @jay I have just reinstalled Endeavour Xfce using the latest beta ISO endeavouros-devel-2019.07.16-x86_64
I can confirm that after updating the fonts in the terminal are blocks. I set the preferences in the terminal to have the fonts set as DejaVu Sans Mono Block. I also found the fonts in mousepad were also blocks when i tried to use it in terminal. It is now set to Mono space regular. I have no blurred characters and everything is good. I found if you set it to use system fonts that it wasn’t any good. This is all you have to do to have clear proper text in the terminal.
Installing the lts kernel is not going to change the fonts. If you type xos4 in the font box that’s what they look like.



Screenshot_2019-07-31_19-40-32

1 Like

The problem is caused by latest pango update
https://bbs.archlinux.org/viewtopic.php?id=248032

You can set monospace font to be used by your system like @ricklinux said or downgrade the package while you wait for a new update.

Install downgrade
sudo pacman -S downgrade
downgrade pango
version 1:1.42.4-1 is working fine.

2 Likes

@fernandomaroto I purposely reinstalled just to confirm there was this issue because it’s throwing some people off. I didn’t know which package was causing the issue but thanks for bringing it to our attention. The other issue is that it is generating ALL the locales which makes the install very slow. I don’t recall this happening on previous installs. Is it not supposed to set the locale for the country you pick in the installer?

@ricklinux when i set it to use system fonts on mine, it looks fine. I did a few other installs in my system with xfce and I’m having the same issue All the way through now, but system fonts do look fine on my end. The rest for me are blurred and squished. I don’t think i seen the other fonts as blocks for me, but I’ll double check after i get done reinstalling.

As @fernandomaroto has said you can downgrade the pango package if you like until the new update fixes the issue. Okay! This is coming from Arch.

1 Like

Last question I promise @ricklinux can I just get rid of the pango package or does that depend on anything else in the system?

It’s a library for rendering text so ya i think so.

Thanks @ricklinux Thank you @fernandomaroto for putting that there to make it easy after install/upgrade