Terminal based apps in Cinnamon still won't work without editing commands

So, switched terminal in Cinnamon from Tilix to Xfce4 terminal. I find i don’t use Tilix’s all functions so a twice the memory usage and far less snappy made it an easy decision to go back to my favorite terminal.

However, I find that terminal based apps that works in Suse, Manjaro and Fedora, not to mention EndeavorOS Xfce, won’t work still.

It is an easy fix, but even after switching to Xfce4 terminal I still have to go to the Cinnamon menu editor and change for example htop from “htop” and “run in terminal” to “xfce4-terminal -e htop” and then uncheck “run in terminal”. Same with Ranger. So it’s not Tilix’s fault.

And yes, on Manjaro Cinnamon I was running xfce4 terminal, and I had completely removed Gnome terminal there too, just as here. But it worked. I have NO idea why.

After more than a year using tilix, 3 days ago i switched to terminator;

Reason:

  • not using tilix dropdown as before (though it’s still installed and configued)
  • terminator can zoom in and zoom out the font while pressing Ctrl + mouse scrooling

since i use nemo (from cinnamon) i also had to change nemo from using tilix to terminator. gsettings set org.cinnamon.desktop.default-applications.terminal exec terminator as stated in https://wiki.archlinux.org/index.php/Nemo#Change_the_default_terminal_emulator_for_Nemo

That’s the thing though; I am on Cinnamon proper, not Xfce with Nemo, and it seems it just refuses to run ANY terminal-based apps without that little workaround regardless of what terminal I have installed and set as default.

1 Like

Yes in my case i only configured nemo.
I think cinnamon should have a way to set the terminal for the entire DE, maybe it does.

Oh it does. And it works, except it won’t run any terminal based apps unless you edit their shortcuts.

maybe you need to set the terminal at /etc/environment or even your bash or zsh config file…

With the easy workaround it works, tho. But if it didn’t I might have to look into that.

1 Like

Works fine with the Gnome terminal that comes in Cinnamon. Open as root, open in terminal, open any app.
:slightly_smiling_face:

I tested, reinstalled Gnome terminal.

Yep, it is working. But when switcing back to Xfce4 terminal as default, it still opens Htop and Ranger in Gnome Terminal.

Edit: interestingly enough in any event if you start a terminal-based app via an icon, the terminal window has no name (just terminal: - ) while if you run it with text command it’s “Terminal: Ranger etc etc”.

However this seems to be by design since looking at screenshots online all of them has that. So that’s not just my computer.

I’m not sure i understand exactly. If i open htop in the terminal it just opens htop in the terminal. If i open an app in the terminal it opens the app.







I only use Gnome terminal because xfce won’t work the way i want it to. Open in a terminal via right click on folders.

Htop and ranger creates app icons. If I click on those I EndeavourOS xfce, Manjaro (any DE) it automatically starts the app in a terminal.

But if I specifically run Cinnamon and have any other terminal than Gnome terminal it doesn’t work.

To clarify when I ran Manjaro cinnamon with Xfce terminal as the only terminal it did work.

I hear what your saying. Have you tried Termite?

1 Like

Not this time :slight_smile: Just put Xfce back, because I might not be a distro hopper but I am a DE hopper…

Ive been doing that a bit too. I find installing plasma not so good though. I don’t like the slowness of the logon with sddm. Plus i just can’t set it up to my liking. I’m used to Cinnamon so some of these other features like app icons i haven’t seen. It almost sounds like an electron app.

I am also one of the few people who just don’t like Plasma. I don’t even know why, it just have never clicked with me.

Exactly…i just don’t get it either. :wink:

1 Like