Terminal based app keep opening xfce4 termimal when clicking "Open with"

Is there a way to change default terminal emulator when clicking “open with”?

I already change it via xfce settings manager for default command emulator, but it didn’t work as expected when clicking “open with”.

Btw, i use i3 window manager, fresh install endeavouros.

If you guys have any solution for this, let me know.
Thanks.

1 Like

Yes, just changed the key binding in your i3 config to whatever emulator you prefer.

Wait, are you using xfce+i3 together?

no, just using i3 and xfce4-terminal as default. That is why i want to change the terminal emulator to kitty.

also, i did that too but still doesn’t give what i expected

Welcome to the forum @Kirima :partying_face: :tada: :balloon: :enos_flag:

1 Like

Open Xfce Settings Manager.

Select Preferred applications. (reference picture here)

In there, switch to Utilities tab and change your terminal emulator.

https://docs.xfce.org/xfce/exo/preferred-applications

Thanks :relaxed:

I already did this, but somehow still not working, altough anything else like “open terminal here” opens Kitty termimal.

Could you give an example in which case Kitty doesn’t open? I could try doing that on my system and check.

you want to change the i3-sensible-terminal ,(how it might call) ?

if you do in .profile in your home do : export TERMINAL=/usr/bin/kitty

after reboot, if you do i3-sensible-terminal it takes kitty atleast or somewhere else but i think xfce4-terminal is also in settings if you change that also take kitty for that

Sure, this is what happens when i right click “open with neovim”

I want to change from xfce4-terminal to Kitty, the only problem relies when right clicking the “open with neovim” or choose “neovim” from rofi menu, it opens another terminal emulator instead of just opening “kitty” terminal.

This somewhat working when opening from rofi, but doesn’t work when trying to right click “open with neovim” in thunar :frowning:

in Thunar is custom probably the case.

if terminal is n prefered application proper configured try exo-open --launch TerminalEmulator vim

to test if that doesnt then that does not work

From what i can tell, “Open with terminal here” is opening kitty terminal correctly, but my only issues is just “open with neovim” which is today i can’t even do anything.

It does work when running that from terminal emulator, i already tested it.

this should do ;

mentioned there was a bug

3 Likes

Yeaahhh, this is what i’m looking for. Thank you @ringo for the solution :heart:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.