Tap To Click on AwesomeWM

Well there’s no section for awesomewm so I put in here. But anyway I started using awesome wm. Loved it but how to activate tap-to-click.
I know tapping and other touchpad settings are configured either through XInput2 as “device properties”, or through Xorg.conf as settings for the ‘libinput’ driver.
So I ran
xinput set-prop ELAN0650:01 "libinput Tapping Enabled" 1
But It showed
unable to find device ELAN0650:01
So i have no idea what to do
Thanks!

xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ ELAN0650:01 04F3:304B Mouse             	id=10	[slave  pointer  (2)]
⎜   ↳ ELAN0650:01 04F3:304B Touchpad          	id=11	[slave  pointer  (2)]
⎜   ↳ Wacom HID 50DE Finger                   	id=13	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ EasyCamera: EasyCamera                  	id=9	[slave  keyboard (3)]
    ↳ Wacom HID 50DE Pen                      	id=12	[slave  keyboard (3)]
    ↳ Ideapad extra buttons                   	id=14	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=15	[slave  keyboard (3)]

just started using Awesome myself, solved it by doing this:

create /etc/X11/xorg.conf.d/70-touchpad-settings.conf

add folowing in that file, and reboot

Section "InputClass"
    Identifier "Touchpads"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
EndSection
1 Like

Thanks you so much!
With the rise of awesowe users perhaps it should have its own topic?

1 Like