Systemdudev slow shutdown or restart

Shutdown and or restart takes too long waiting for process systemudev.

[dan@dan-pc ~]$ inxi -FGz
System:
  Host: dan-pc Kernel: 5.5.10-arch1-1 x86_64 bits: 64 
  Desktop: Cinnamon 4.4.8 Distro: EndeavourOS 
Machine:
  Type: Desktop Mobo: Micro-Star model: X570-A PRO (MS-7C37) v: 3.0 
  serial: <filter> UEFI: American Megatrends v: H.70 date: 01/09/2020 
CPU:
  Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP 
  L2 cache: 4096 KiB 
  Speed: 2504 MHz min/max: 2200/3700 MHz Core speeds (MHz): 1: 2732 2: 1802 
  3: 2114 4: 2113 5: 1865 6: 2775 7: 1870 8: 1729 9: 1805 10: 1808 11: 1718 
  12: 2422 13: 1720 14: 1720 15: 2559 16: 2107 
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] driver: nvidia v: 440.64 
  Display: x11 server: X.Org 1.20.7 driver: nvidia 
  unloaded: fbdev,modesetting,vesa resolution: 1680x1050~60Hz 
  OpenGL: renderer: GeForce GTX 1650 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 440.64 
Audio:
  Device-1: NVIDIA TU116 High Definition Audio driver: snd_hda_intel 
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.5.10-arch1-1 
Network:
  Device-1: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network 
  Adapter 
  driver: wl 
  IF: wlan0 state: dormant mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 4.55 TiB used: 9.61 GiB (0.2%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G3X0C-00SJG0 
  size: 465.76 GiB 
  ID-2: /dev/sda vendor: Western Digital model: WDS500G2B0A-00SM50 
  size: 465.76 GiB 
  ID-3: /dev/sdb vendor: Seagate model: ST4000DM004-2CV104 size: 3.64 TiB 
Partition:
  ID-1: / size: 448.50 GiB used: 9.61 GiB (2.1%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 38.5 C mobo: N/A gpu: nvidia temp: 33 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 25% 
Info:
  Processes: 324 Uptime: 4m Memory: 31.38 GiB used: 1.22 GiB (3.9%) 
  Shell: bash inxi: 3.0.37 
[dan@dan-pc ~]$ 

Boot Log
http://ix.io/2eO6

The logs didn’t really show me anything so i it seemed to be lvm2 causing the shutdown slowness. I shutdown lvm2 services and seems instant off now. I’ll run it a little more and see.

[dan@dan-pc ~]$ systemctl status lvm2-lvmetad.socket
● lvm2-lvmetad.socket
     Loaded: masked (Reason: Unit lvm2-lvmetad.socket is masked.)
     Active: inactive (dead)
[dan@dan-pc ~]$ 

This seems to have worked as the computer shuts off instantly and reboots what waiting.