Systemd-udevd[314]: could not read from '/sys/module/pcc_cpufreq/initstate'

systemd-udevd[314]: could not read from '/sys/module/pcc_cpufreq/initstate': No such device

Anyone knows what causes this? I suspect there is a plugin or something that tries to check on hardware? Nothing dangerous but just curious.

inxi -Fxxxza --no-host ?

What exactly are we looking for? it’s a big chunk of data… :wink:

It is a standard help request. :man_shrugging: Hard to help without knowing the hardware involved. BIOS info, kernel etc…

1 Like
System:    Kernel: 5.10.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=07d6b3fc-6ee3-4575-b507-ea06675c2ccb rw 
           rootflags=subvol=@ quiet loglevel=3 nowatchdog 
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: EndeavourOS 
Machine:   Type: Desktop System: LENOVO product: 90JL00E8MW v: Legion T530-28ICB serial: <filter> Chassis: type: 3 
           serial: <filter> 
           Mobo: LENOVO model: 36E7 v: SDK0J40700 WIN 3258129188066 serial: <filter> UEFI: LENOVO v: O3LKT20A date: 03/07/2019 
CPU:       Info: 6-Core model: Intel Core i5-8400 bits: 64 type: MCP arch: Kaby Lake note: check family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: DE L2 cache: 9 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33599 
           Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e92 
           Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Micro-Star MSI driver: nvidia v: 460.32.03 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c82 
           Display: x11 server: 1.20.10 driver: nvidia resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 
           Device-2: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0fb9 
           Device-3: GN Netcom Jabra EVOLVE 65 type: USB driver: jabra,snd-usb-audio,usbhid bus ID: 1-3:2 chip ID: 0b0e:030c 
           serial: <filter> 
           Sound Server: ALSA v: k5.10.8-zen1-1-zen 
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo driver: rtw_8821ce v: N/A 
           modules: rtw88_8821ce port: 4000 bus ID: 03:00.0 chip ID: 10ec:c821 
           IF: wlan0 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 4.66 TiB used: 8.58 GiB (0.2%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM128GDHTNG-8310B size: 119.24 GiB block size: 
           physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: 80070C00 temp: 39.9 C 
           ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1A02 
           ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital model: WD40EZRX-00SPEB0 size: 3.64 TiB block size: 
           physical: 4096 B logical: 4096 B serial: <filter> rev: 1065 
Partition: ID-1: / raw size: 48 GiB size: 48 GiB (100.00%) used: 8.53 GiB (17.8%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5 
           ID-2: /boot/efi raw size: 260 MiB size: 256 MiB (98.46%) used: 52.3 MiB (20.4%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw size: 48 GiB size: 48 GiB (100.00%) used: 8.53 GiB (17.8%) fs: btrfs dev: /dev/nvme0n1p5 
           maj-min: 259:5 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A gpu: nvidia temp: 46 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 29% 
Info:      Processes: 254 Uptime: 6m wakeups: 0 Memory: 15.51 GiB used: 1.72 GiB (11.1%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 Packages: pacman: 935 lib: 276 Shell: fish v: 3.1.2 running in: xfce4-terminal inxi: 3.2.01 

It is related to intel p_state. Old one that should have been fixed. Maybe reared its head again with new kernel.

So adjust BIOS settings or add a kernel parameter.

1 Like

Thank you!

I also didn’t realize until now I forgot to set a Swap in my new partition scheme. Oh well.

You have 16Gib of ram so unless you use VM’s regularly should be ok. You could always add a swapfile after.

1 Like

Oh I know, it’s more habit. :slight_smile:

I’ve just got this error
but I didn’t understand the solution :slight_smile:
please, could you explain me how you solved the problem? :slight_smile:

What kernel do you use, because this should be fixed by now?

last kernel, zen

Huh, I didn’t get that error after today’s update.
And I have reinstalled completely since that post, several times too, so the solution then can’t have stuck.

Does it work with another kernel for you?

I’ve got the same error with the “normal” kernel, not the zen one :slight_smile:

I have the same error with last “regular” kernel too Kernel: 5.13.9-arch1-1