Systemd trying to run non-existent service (sunshine) on boot

At one point, I tried (and failed) to get sunshine working on my machine. Now, when looking at the system journal via KSystemLog, I see the following error message:

sunshine.service: Failed at step EXEC spawning /usr/bin/sunshine: No such file or directory

When running systemctl status sunshine, I receive the following error message: Unit sunshine.service could not be found. Appending sudo produces the same result.

How can I stop systemd from trying to run this non-existent service?

sudo systemctl disable sunshine

Which is pretty much the default for the UK :rofl:

1 Like

sudo systemctl disable sunshine.service Should do it…

Oops…posted too late…

I get this error message: Failed to disable unit: Unit file sunshine.service does not exist.

Do you have some file related to sunshine in /etc/xdg/autostart?
If you have you can remove it, reboot and check the logs again and see if that message is gone.

No, but I figured it out. I had to run systemctl --user disable sunshine. Haven’t rebooted yet, but I’m sure that will have been it.


That must be it. It’s a user and not a system service then. Good find!