Systemd-boot unable to find correct boot partition

Hey everyone,
I recently wanted to migrate from GRUB to Systemd-boot and I figured the easiest way is to reinstall the entire operation system. However, I selected the systemd-boot option from the options and when I try to select the correct boot partition (which is premade by windows on my nvme0) I am not able to select it. In fact, I am not even able to see it in the dropdown list. The only boot partition that shows up is the USB-Sticks boot partition.
Using GRUB Bootloader however worked perfectly fine and it found the correct boot partition instantly.
It’s not that big of a deal, just thought that it might be the better choice since it is label with ‘recommended’.
Has anyone else have that problem before or is that an issue on my side?

A default installation of EnOS’ with systemd-boot needs an ESP of the size 1G since that is where all the kernel images are going to reside.

If you are choosing manual installation, you need to create one yourself, flag it as boot and mount it at /efi.

If you choose the automatic installation, the installer would create this for you.

Note also, if this is an installation on the same disk where Windows reside, systemd-boot would create automatically a boot menu entry for Windows.

If this is an installation on another disk, some more work needs to be done on the part of the user to create this boot entry for Windows.


Okay, thank you!
I’ll try that out then!

1 Like

For anyone reading this at a later stage,
like pebcak said: Create a new boot partition on your drive that is at least 1G in size and then add the boot and esp flags to that partition using GParted.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.