System won't update with yay

So when I tried to update, I get this:

[mark3@mark3-optiplex9020 ~]$ yay
[sudo] password for mark3:
:: Synchronizing package databases…
error: failed to synchronize all databases (no servers configured for repository)
→ error refreshing databases - exit status 1
[mark3@mark3-optiplex9020 ~]$

I tried to look at the mirrorlist with this command:
sudo nano /etc/pacman.d/endeavouros-mirrorlist

and it comes out BLANK. How could that have disappeared?

For just looking at the content of a file you don’t need sudo nano. This is what you use when you want to edit a file which requires root privilege.

You can use cat:

cat /etc/pacman.d/endeavouros-mirrorlist


update your mirror lists(EndeavourOS and Arch) e.g. with the welcome app.

1 Like

I tried that too, but I’ll give it another go…

1 Like

Check with ls /etc/pacman.d to see if the file is there.

If it is not, download this file:

comment out the servers you don’t want to use and put it in /etc/pacman.d.

Looks like on the second try updating the arch mirrorlists fixed it, so now I get :
[mark3@mark3-optiplex9020 ~]$ yay
:: Synchronizing package databases…
endeavouros is up to date
core is up to date
extra is up to date
multilib is up to date
:: Searching AUR for updates…
:: Searching databases for updates…
there is nothing to do
[mark3@mark3-optiplex9020 ~]$

Errors are gone…

how long have you not updated?

Less than a week. This is my wifes machine, so sometimes it happens less often with hers…

updates are usually available daily. something doesn’t seem right.

I had the same thing happen on one of my other machines over a week ago, and updating the Endeavor mirrorlists fixed that one. It’s been fine since.

This morning when I ran yay, it did manage to update all the files, though it did spit out the errors I started the thread with. Then got worse from there…

It even managed to update two aur programs, one being zoom, but yay wouldn’t even work after that until I updated the arch mirrorlists.

Just to remind, you have two separate mirrorlist files that need to be OK:

  1. /etc/pacman.d/mirrorlist (the Arch mirrors)
  2. /etc/pacman.d/endeavouros-mirrorlist (the EndeavourOS mirrors)

Both can be updated using the tools in the Welcome app.

Other tools which are able to update them are:

  1. rate-mirrors, reflector, reflector-simple (the Arch mirrors)
  2. eos-rankmirrors, rate-mirrors (the EndeavourOS mirrors)

Both of those mirrorlist files should have lines defining mirrors.
A line defining a mirror starts with something like this:

Server = https://

There must not be any comment marks (#) before the text on the line.
If every line is commented with ‘#’, then mirrors are not OK in that file.