System won't start after updating and rebooting

PXL_20201230_130418847

I tried the normal kernel and the zen kernel and the tkg kernel. All the same. Tkg does not work since 5.10 but the normal kernel and the zen kernel are still 5.9.

Ctrl alt f1 etc also does nothing. How can I get a prompt? Or a solution if anyone knows.

Also got this after a while waiting.

16093336815583698970919037843101

this is on normal kernel ?

Zen, but can also do normal.

Doing that now. So far it’s this with my GPU fans spinning hard.

16093339580186819915592278442795

1 Like

I can enter grub. Can I use timeshift in grub?

Chroot from the live media, you can restore from there. On my way out, back in a bit, but @ringo can point you at the instructions I’m sure :smiley:

https://wiki.archlinux.org/index.php/chroot

Back in a bit.

I got this after waiting with the normal kernel.

PXL_20201230_131447800

Then I need to find a way to make a live media. Dang.

Do you have access to another computer? OS does not matter. Think you can even do it from an Android phone (never tried here).

Right must go…

chrooting is just basic mounting and then arch-chroot

cannot tell what happend see you have amdgpu…mayby to begin mkinitcpu -P and regenerate grub

to start…i would personally remove that tkg kernel also

1 Like

Strange. With only 1 monitor it works.

Read Here:

Similar:

1 Like

Something to look into. I am now in my desktop again. With a single monitor I can boot.

Then at the desktop I plug in my monitors and then with the terminal “/usr/lib/cinnamon-settings-daemon/csd-xrandr --exit-time=3” I let my display’s being detected again and then it is all good.

Now I at least got time to help troubleshoot and make my bootable usb.

If you don’t have a bootable usb, you could try falling into a root shell and restore your timeshift snapshot.

On the boot entry in Grub menu press the e key. This allows you to edit the kernel parameters before booting. Use the arrow keys to navigate to the line that looks like linux /vmlinuz=linux root=UUID=.... .

Add init=/bin/sh to the boot parameters and press ctrl-x to boot. If that works you will get into a root shell.

Use timeshift --help to get a list of command line options.

edit: I see that problem is sorted out somehow. Please ignore this post.

1 Like

Let me guess the monitors are using displayport?

2 monitors on DP indeed and the other is HDMI (my 4k TV).

1 Like

Still very helpful, saved it for in the future!

2 Likes

Well according to what i have read so far 2 x display port is the problem but 1 x display port and 1x hdmi is fine. At least you got back in to troubleshoot. If you need two monitors i would just (temporarily) swap one over to hdmi.

1 Like

Thanks for the info, that is good to know. Means I don’t have to disconnect 2, or any if I go with HDMI.

The method I described before doesn’t look to be suitable for restoring a Timeshift’s snapshot.
In the root shell it gives a list of command lines runnig timeshift --help but then running timeshift --list didn’t recognize any of the snapshots I have in the system. Wonder why? I haven’t have time to look into it further.