System won't boot after update

Hello, i need some help because i’ve updated and now the system won’t boot the first times the login screen worked, i typed my password and the system seemed to boot and let a black screen and after some few second the system backed up me to the login screen. Today i’ve not the login screen i’ve just a black screen after the boot of the system. Please note before that i was unable to update because of the package pcsx2 (ps2 emulator) so i uninstalled it and i’ve updated pacman and yay, and this result me to this situation.
I’ve Lxqt, i usueally use the zen kernel, i have the normal kernel and the lts too. LTS won’t boot too.
Thank you all

Edit: i often use before the file which change the date of the update for have a system functionnal as before, i search that but i don’t find it

Hi @shroungek
If you are using Grub as bootloader maybe you can search here in the forum how to fix it.
If it is sytemd-boot, then, I will be following up with you here what the experts here would suggest to learn more.

1 Like

how you uninstalled this? (exact command) could be you removed needed packages with it.

ah and indeed: welcome at the forum :enos:

And some mor einfo will be needed.

Graphics card and driver can be an issue we all know about Nvidia can do that.
And it seems you can still login to TTY? (CLI login without X)

1 Like

would need also some more info is this the bootloader or the DM ? early boot or late to login to Desktop?

Thanks you guys for youre response, so i guess it was on my Desktop Manager if iam right, with my name user and my PassWord.
And i uninstall pcsx2 via : yay -R pcsx2

For the info you need to know more about the hardware? I have the cpu I7 4790k and a gpu 980GTX and i use the default driver on this install because i don’t play to any games atm.

Thank you for your welcome :grinning:

For TTY i just knowed this word today because iam not an advanced user on linux but i am able to connect to my os via arch-chroot.
I use GRUB but i precise that i have windows 10 on another ssd and i have some issue to boot it too, but it is functionnal now. And yep i tried yesterday to downgrade grub to the previous version but i’ve failed to downgrade.

Let me know if you wanna know more for my info :v:

Edit: for: “would need also some more info is this the bootloader or the DM ? early boot or late to login to Desktop?”
The boot time is correct maybe a little bit later than the normal situation but iam really not sure of this.

if it is the DM and system just boots fine as you said like early boot menu is there and you can boot system but DM (Desktop Manager) is failing to start the session itself first boot and after it it does not show up again and system boots to show only blinking cursor or pure black screen?

gpu 980GTX so you install using “default” without Nvidia drivers and running on open source nouveau dirvers from kernel?

In this case i do not see why it would not be able to show the DM.

TTY is the direct terminal input without graphical login you can reach and login by pressing Ctrl+Alt+F4 this will start a login prompt where you can login as user and run commands… so you will be able to remove packages edit configs e.t.c. without the need to arch-chroot … because the system is functional also you do not have X running :wink:

Grub is known to be problematic and causes the problem of having unbootable systems.

The default now during installation is systemd-boot.

So, you have 2 options:

  • search the forum here on how to fix the grub issue
  • convert bootloader from Grub to systemd-boot
    If you have your data on a separate partition or have them backed up, if I were in your place, I would do a fresh install with systemd-boot (easier for me than doing all the stuff to fix Grub and convert to systemd-boot, sorry I am a bit impatient!)

I hope this helps.

So now strangely DM boot up (with the login and the password to type) but today he does what does the first time: he seems to boot with the blackscreen just before he display the desktop but the black screen stay 1 sec and back me up to the login screen with the password that i have to type again.
That strange because yesterday that was just a black screen with nothing not even with mouse cursor, no blinking too.
I have to precise i made a mistake because i had install on this linux the nvidia driver for gaming and not the default driver so i think i have the nvidia-inst. It seems to be this as you said @joekamprad, i think it was a fresh install of endeavouros and i have not played to any games on it this last year.
Sorry for this mistake. Thank you for this tips TTY works now so :+1:
Ok so iam openminded @limotux to try another bootloader i will try to uninstall grub and install systemd-boot, I’ll keep you informed, thanks :slightly_smiling_face:

if so you could simply revert to open source nvidia drivers or try reinstalling drivers with nvidia-inst script…

revert to open source drivers:
nvidia-inst -n

I tried it so i have some errors:

error: hook /usr/share/libalpm/hooks/update-vlc-plugin-cache line 1 wrong option 0\r***
error: transaction validation failed (transaction hooks could not be executed)
(the * was some tile in fact)

I translated the error from french.

is in use?

You can make a picture with smartphone in case … or you will need to try describe exactly what the output shows… the error is not related to the driver issue… and may came up on installing packages… while running nvidia.inst?

pacman -Q tell me :
vlc 3.0.18-13
the output exactly show me that:
error: hook /usr/share/libalpm/hooks/update-vlc-plugin-cache line 1: invalid option 0\r***
error: failed to commit transaction (failed to run transaction hooks)

the ‘*’ is in fact a tile with a ‘?’ inside

I’ve always use nvidia-inst but i don’t think i ran while i was installing some packages. But something relevant for me is that reallye often i’ve some issue for updating pacman and yay. Until today i updated the keyring thats solved the issue now it’s not working. :confused:
Maybe i have to make a fresh install i don’t know …

EDIT: Oh i have to tell now ctl + alt + F4 doesn’t work now (after i tried to install nouveau)
I did this from chroot.

EDIT2: And when i played on steam i used the multilib repo maybe that is not helpful too, or it was chen i was on arch :thinking:

installed nouveau from chroot or try the key combination?
If nvidia-inst -n is what your where running from chroot it could be you need another F* key
to reach a usable TTY 1-7 are available…

And if nouveau leads to exact the same issue… it is not the GPU driver causing your issue…
could be also something you screwed onnusers home permission wise or something with configuration… causing that it can not start the session.

What i would do is creating a new test user and try login to Dektop with this one:
sudo useradd -m -G wheel -s /bin/bash testuser
sudo passwd testuser
sudo systemctl restart sddm
and login as testuser…

I tried to install it (but it failed ) with the combination. Ok i will try this.
The edit from last post forget to say this:
And when i played on steam i used the multilib repo maybe that is not helpful too, or it was when i was on arch :thinking:

As chroot i can not restart this, how i can do in other way? the 2 others command worked.

my brain is just tired :sweat_smile: because i use everyday the zen kernel and i have installed it just for the games, i don’t know i was convinced that was a fresh install :face_in_clouds:

edit: *new install

still not solved?
i was busy and not fully understand if you try the suggested things and why you chroot now? is TTY not working ? you do still not say that exactly…

it will never solved lol i have decided to format (installing again EOS) so i did this and i’d try systemd-boot, thats have broken windows boot manager, and i lost my usb key with the windows installer :melting_face: so now i prepare a new usb key. I did this because i couldn’t install or try something else. Even if i couldn’t did the 3rd commande i had to try to log with this ‘testuser’ :man_shrugging:

i want to precise thats broken windows boot manager and now i don’t know how to do because it seems that i can’t see the esp partition of windows. I see just the windows data and the miccrosoft reserved partition but i can’t mount it, it seems not accessible, his PARTUUID is really not easily readable. So it seems that i can’t rescue windows boot manager from linux.

I did this tutorial, the usb key is ready soon so wish me gl
The risk is that if I do this is to break, again, the boot loader of the other OS. If you have any advice i take it.