System shuts down after waking from suspend

Hi, my PC shuts down when I try to wake it from sleep. So it goes to sleep > then I press a keyboard to wake it up > the system tries to power on and then it shuts down (monitor doesn’t get to wake up because the PC shuts down before it does so).
I’ve checked journalctl and it says like this:

eb 20 22:27:18 schmitz-x570aorusultra systemd[1]: user@120.service: Deactivated successfully.
feb 20 22:27:18 schmitz-x570aorusultra systemd[1]: Stopped User Manager for UID 120.
feb 20 22:27:18 schmitz-x570aorusultra systemd[1]: Stopping User Runtime Directory /run/user/120...
feb 20 22:27:18 schmitz-x570aorusultra systemd[1]: run-user-120.mount: Deactivated successfully.
feb 20 22:27:18 schmitz-x570aorusultra systemd[1]: user-runtime-dir@120.service: Deactivated successfully.
feb 20 22:27:18 schmitz-x570aorusultra systemd[1]: Stopped User Runtime Directory /run/user/120.
feb 20 22:27:18 schmitz-x570aorusultra systemd[1]: Removed slice User Slice of UID 120.
feb 20 22:27:18 schmitz-x570aorusultra systemd[1]: user-120.slice: Consumed 1.786s CPU time.
feb 20 22:27:23 schmitz-x570aorusultra dbus-daemon[1317]: [session uid=1000 pid=1317] Activating via systemd: service name=>
feb 20 22:27:23 schmitz-x570aorusultra systemd[1296]: Starting Tracker metadata extractor...
feb 20 22:27:23 schmitz-x570aorusultra dbus-daemon[1317]: [session uid=1000 pid=1317] Successfully activated service 'org.f>
feb 20 22:27:23 schmitz-x570aorusultra systemd[1296]: Started Tracker metadata extractor.
feb 20 22:27:28 schmitz-x570aorusultra systemd-timesyncd[719]: Contacted time server 129.70.132.33:123 (2.arch.pool.ntp.org>
feb 20 22:27:28 schmitz-x570aorusultra systemd-timesyncd[719]: Initial clock synchronization to Mon 2023-02-20 22:27:28.454>
feb 20 22:27:31 schmitz-x570aorusultra gnome-shell[1383]: Error connecting to the screencast service
feb 20 22:27:37 schmitz-x570aorusultra systemd[1]: systemd-localed.service: Deactivated successfully.
feb 20 22:27:37 schmitz-x570aorusultra systemd[1]: systemd-hostnamed.service: Deactivated successfully.
feb 20 22:28:02 schmitz-x570aorusultra geoclue[1043]: Service not used for 60 seconds. Shutting down..
feb 20 22:28:02 schmitz-x570aorusultra systemd[1]: geoclue.service: Deactivated successfully.

here are my specs:

image

Does anyone have any suggestions?