System randomly refusing to open applications

Before i start just want to say that is my first time on a forum and that i am not a native in english and that the error started after some updates, i also tried to re-install the whole OS but it did not fix the issue.

Now, about the error:

After some time with my system on it start to refuse to open applications and just keep loading for some time, when this happen i can’t turn off the system because the exit menu suffer from the same error and the terminal refuses to execute commands, the only applications that run are some of the default ones that come with endeavour.

I have been trying my best to get the most information about the error possible but is not easy because the error just start after a good amount of time with OS open and also are random. I tried to get the journal from the last time that the error happened (today at 13:40) using journalctl -b -1 but the only thing that i got was “Data from the specified boot (-1) is not available: No such boot ID in journal”

Most of the logs are extreme big because of a message error that i could not fix that keep spaming my logs with all distros that i tried (going to put it in the end of the post).

I have limited knowledge on linux and also the endeavour-log-tool don’t allow big logs so the only thing that i could get was this:

inxi -Fxxc0z --no-host | eos-sendlog


The error message that i was talking about:
nov 10 15:25:57 System kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
nov 10 15:25:57 System systemd-journald[3442]: Missed 38 kernel messages
nov 10 15:25:57 System kernel: pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5

All linux distros that i used had this error message, tried everything that i could to fix it but i had give up because is not doing anything noticeable.

If there is something missing let me know that i will try my best to post it here.

You could try a kernel parameter in the default grub command line and then update grub just to see if it boots properly.


Edit: Add it in /etc/default/grub after “quiet”

Update grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg

You would have to do this from a TTY if you can boot and get into it.

1 Like

Thank you for the reply! I tried this and it appear that the message error are gone for now thanks for that. I will check to see if the other error still is happening, this time since my journal are clean i will use the journalctl -f to check if something appear before the error. Thanks again for the help!

Could you post

inxi -Faz --no-host | eos-sendlog


sudo dmesg | eos-sendlog


journalctl -b -0 | eos-sendlog

So you are able to boot now so that’s good. It will use more power with aspm off. What you want to do is try to figure out what is the cause. Check your Bios version and date and see if there is an update for this motherboard.


There are two newer Bios updates for that board. I would suggest to update to the latest version and then try booting without the kernel parameter. You would have to remove it and update grub again after updating your Bios. If it still has same issue you can add the parameter back.

1 Like

(post deleted by author)

I already updated my bios 2 months ago, had some other issues with my old OS.

1 Like

That looks better. I see in dmesg that pcie aspm is off. Nothing stands out? See if you have any more issues and or errors but you need to update the UEFI Bios.

Edit: Okay i see the new log shows the correct latest Bios.

1 Like

Not sure what update would have caused this. Now you can see how it works and see if you get anymore problems.

1 Like

Random errors could be caused by heat problems as well.
Can you find information about the temperatures (e.g. program glances)?

1 Like

Yes, i already checked the hardware for error, the temperature is good and everything is working. For now i am going to put this post as solved, it appear that the error is gone for now. In case the error is still happening i will create a new post with better information and with the journal. Thanks everyone for the help! i really appreciate it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.