System Laggy/unresponsive, after screens have been turned off

ok, weird issue that I’ve been trying to hunt down.
Running KDE/plasma
AMD video card, with the standard MESA drivers (AFAIK)
If I am walked through it, I am willing to provide whatever other info I can

But on occasion, not every time, but say half the time, when my monitors are turned off, and then I come back to use the system, it is very laggy and unresponsive.
Something like opening Firefox can take in excess of three minutes (normally fairly instant).
Even typing, I can type a full sentence, and by the end of it, only the first couple of letters have appeared

Now I wasn’t sure at first what the issue was
so I tried disabling locking my system after inactivity
I also disabled energy saving and turned off my monitors manually with the physical power button, and still got the same effect.

I’m not really sure how to even begin troubleshooting it at this point, it’s annoying to say the least. A quick reboot fixes it, but I really shouldn’t have to reboot a few times a day just because I turned my monitors off.

I would check both top and iotop during those laggy periods to see if anything is consuming a bunch of resources. Also take look at the journalctl output and see if there is anything interesting during those times.

I did check task-manager/top/htop/glances/et.all, didn’t see any extreme, CPU or RAM use, not familiar with “journalctl” or how to check/interpret it. More than willing to do so if I can get some direction

Is there a reason you turn your monitors off as opposed to just putting the system to sleep?

Open a terminal and paste the following in it ans copy and paste the output here.

sudo journalctl -p 3 -xb

edit woops typo.

My system is sort of the household file/media server, so it just stays on 24/7. But I usually put my monitors to sleep when I’m not physically at the keyboard

I added an edit to my last post. You can just put the monitors to sleep as well.

Got an error

journalctl: invalid option -- 'P'

I did put the monitors to sleep original, as said in my post, that’s how the problem started, I tried turning them off manually to see if that changed/fixed the issue, and it did not,
regardless of HOW the monitors turn off/sleep, the issue remains.

yes a typo lowercase p

Ok my bad
here we go
it’s worth noting I restarted recently, like just before posting here:

-- Journal begins at Wed 2021-06-16 17:06:55 EDT, ends at Wed 2021-06-16 17:46:50 EDT. --
Jun 16 17:06:55 Kalevala-Linux kernel: __common_interrupt: 1.55 No irq handler for vector
Jun 16 17:06:55 Kalevala-Linux kernel: __common_interrupt: 2.55 No irq handler for vector
Jun 16 17:06:55 Kalevala-Linux kernel: __common_interrupt: 3.55 No irq handler for vector
Jun 16 17:06:55 Kalevala-Linux kernel: __common_interrupt: 4.55 No irq handler for vector
Jun 16 17:06:55 Kalevala-Linux kernel: __common_interrupt: 5.55 No irq handler for vector
Jun 16 17:06:55 Kalevala-Linux kernel: __common_interrupt: 6.55 No irq handler for vector
Jun 16 17:06:55 Kalevala-Linux kernel: __common_interrupt: 7.55 No irq handler for vector
Jun 16 17:06:55 Kalevala-Linux kernel: __common_interrupt: 8.55 No irq handler for vector
Jun 16 17:06:55 Kalevala-Linux kernel: __common_interrupt: 9.55 No irq handler for vector
Jun 16 17:06:55 Kalevala-Linux kernel: __common_interrupt: 10.55 No irq handler for vector
Jun 16 17:06:55 Kalevala-Linux kernel: sd 2:0:0:0: [sda] No Caching mode page found
Jun 16 17:06:55 Kalevala-Linux kernel: sd 2:0:0:0: [sda] Assuming drive cache: write through
Jun 16 17:06:57 Kalevala-Linux kernel: Bluetooth: hci0: BCM: firmware Patch file not found, tried:
Jun 16 17:06:57 Kalevala-Linux kernel: Bluetooth: hci0: BCM: 'brcm/BCM20702A1-0a5c-21e8.hcd'
Jun 16 17:06:57 Kalevala-Linux kernel: Bluetooth: hci0: BCM: 'brcm/BCM-0a5c-21e8.hcd'
Jun 16 17:07:01 Kalevala-Linux nmbd[1526]: [2021/06/16 17:07:01.422352,  0] ../../lib/util/become_daem>
Jun 16 17:07:01 Kalevala-Linux nmbd[1526]:   daemon_ready: daemon 'nmbd' finished starting up and read>
Jun 16 17:07:01 Kalevala-Linux smbd[1527]: [2021/06/16 17:07:01.505328,  0] ../../lib/util/become_daem>
Jun 16 17:07:01 Kalevala-Linux smbd[1527]:   daemon_ready: daemon 'smbd' finished starting up and read>
Jun 16 17:07:24 Kalevala-Linux nmbd[1526]: [2021/06/16 17:07:24.500028,  0] ../../source3/nmbd/nmbd_be>
Jun 16 17:07:24 Kalevala-Linux nmbd[1526]:   *****
Jun 16 17:07:24 Kalevala-Linux nmbd[1526]: 
Jun 16 17:07:24 Kalevala-Linux nmbd[1526]:   Samba name server KALEVALA-LINUX is now a local master br>
Jun 16 17:07:24 Kalevala-Linux nmbd[1526]: 
Jun 16 17:07:24 Kalevala-Linux nmbd[1526]:   *****
~
~
~
~
~
lines 1-26/26 (END)

Run journalctl -b and navigate to one of the time periods where you had slowness. journalctl is where the vast majority of your logs are so it is worth getting to know how to use it.

Did you check iotop which shows disk utilization?

No I did not. I will have to try that next time it happens …

It might not be installed so you want to do that in advance.

That looks like it is filtered down to only errors. In this case, we want to see all activity, not just errors.

Got iotop installed, ready for next time.

Copy & pasted exactly what you told me, so that’s what I got for now.

Next time it happens I’ll push through the lag, get the konsoles up and send outputs here:

I think you may have posted what @BONK recommended, not me. :slight_smile:

-p 3 limits the output to errors. In a case like this, we aren’t really looking for errors, we are looking for activity.

1 Like

ok was jsut able to reproduce the problem.
Turned off ONLY my secondary monitor for just a second, then back on .
Tried to take screenshots of the konsole, but system is so unresponsive that it took over 5 min to capture one. and as said even typing in Discord or Here is very very slow

think i found where in the log it happened, but it looks like a LOT to try and paste here.

un 16 17:07:02 Kalevala-Linux systemd[1590]: Started MEGAsync - File Synchronizer.
Jun 16 17:07:02 Kalevala-Linux dbus-daemon[1693]: [session uid=1000 pid=1693] Activating service name='org.freedesktop.Notifications' r>
Jun 16 17:07:03 Kalevala-Linux plasmashell[1991]: kf.plasma.quick: Applet preload policy set to 1
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1693]: [session uid=1000 pid=1693] Activating via systemd: service name='org.gtk.vfs.Daemon'>
Jun 16 17:07:03 Kalevala-Linux systemd[1590]: Starting Virtual filesystem service...
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1693]: [session uid=1000 pid=1693] Successfully activated service 'org.gtk.vfs.Daemon'
Jun 16 17:07:03 Kalevala-Linux systemd[1590]: Started Virtual filesystem service.
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1693]: [session uid=1000 pid=1693] Activating via systemd: service name='org.a11y.Bus' unit=>
Jun 16 17:07:03 Kalevala-Linux systemd[1590]: Starting Accessibility services bus...
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1693]: [session uid=1000 pid=1693] Successfully activated service 'org.a11y.Bus'
Jun 16 17:07:03 Kalevala-Linux systemd[1590]: Started Accessibility services bus.
Jun 16 17:07:03 Kalevala-Linux at-spi-bus-launcher[2270]: dbus-daemon[2270]: Activating service name='org.a11y.atspi.Registry' requeste>
Jun 16 17:07:03 Kalevala-Linux at-spi-bus-launcher[2270]: dbus-daemon[2270]: Successfully activated service 'org.a11y.atspi.Registry'
Jun 16 17:07:03 Kalevala-Linux at-spi-bus-launcher[2273]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Jun 16 17:07:03 Kalevala-Linux kwin_x11[1885]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1311, resource id: 50331>
Jun 16 17:07:03 Kalevala-Linux megasync[2138]: Setting QT_SCREEN_SCALE_FACTORS= "DisplayPort-0=1;DisplayPort-1=1"
Jun 16 17:07:03 Kalevala-Linux dotnet[1318]: [17:07:03] [INF] [21] Emby.Server.Implementations.IO.LibraryMonitor: Watching directory /m>
Jun 16 17:07:03 Kalevala-Linux kwin_x11[1885]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1334, resource id: 20971>
Jun 16 17:07:03 Kalevala-Linux systemd[1590]: Started qBittorrent - BitTorrent client.
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Successfully activated service 'org.freedesktop.UPower'
Jun 16 17:07:03 Kalevala-Linux systemd[1]: Started Daemon for power management.
Jun 16 17:07:03 Kalevala-Linux audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=upower comm="systemd" exe=">
Jun 16 17:07:03 Kalevala-Linux systemd[1590]: Started calibre-gui.
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Activating service name='org.kde.powerdevil.discretegpuhelper' requested by >
Jun 16 17:07:03 Kalevala-Linux dotnet[1318]: [17:07:03] [INF] [21] Jellyfin.Networking.Manager.NetworkManager: Defined LAN addresses : >
Jun 16 17:07:03 Kalevala-Linux dotnet[1318]: [17:07:03] [INF] [21] Jellyfin.Networking.Manager.NetworkManager: Defined LAN exclusions :>
Jun 16 17:07:03 Kalevala-Linux dotnet[1318]: [17:07:03] [INF] [21] Jellyfin.Networking.Manager.NetworkManager: Using LAN addresses: [12>
Jun 16 17:07:03 Kalevala-Linux systemd[1590]: app-calibre\x2dgui-b48a21660c4c4daba1bf2534d1284d0a.scope: Deactivated successfully.
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Successfully activated service 'org.kde.powerdevil.discretegpuhelper'
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Activating service name='org.kde.powerdevil.chargethresholdhelper' requested>
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Successfully activated service 'org.kde.powerdevil.chargethresholdhelper'
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Activating service name='org.kde.powerdevil.backlighthelper' requested by ':>
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='d>
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.s>
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='d>
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.s>
Jun 16 17:07:03 Kalevala-Linux kded5[1881]: kf.modemmanagerqt: Failed enumerating MM objects: "org.freedesktop.systemd1.NoSuchUnit" 
                                             "Unit dbus-org.freedesktop.ModemManager1.service not found."
Jun 16 17:07:03 Kalevala-Linux backlighthelper[2317]: org.kde.powerdevil: no kernel backlight interface found
Jun 16 17:07:03 Kalevala-Linux kded5[1881]: bluedevil: ObexManager operational changed false
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1693]: [session uid=1000 pid=1693] Activating via systemd: service name='org.bluez.obex' uni>
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1693]: [session uid=1000 pid=1693] Activating service name='org.kde.KScreen' requested by ':>
Jun 16 17:07:03 Kalevala-Linux systemd[1590]: Starting Bluetooth OBEX service...
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Activating service name='org.kde.kded.smart' requested by ':1.19' (uid=1000 >
Jun 16 17:07:03 Kalevala-Linux obexd[2325]: OBEX daemon 5.59
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1693]: [session uid=1000 pid=1693] Successfully activated service 'org.bluez.obex'
Jun 16 17:07:03 Kalevala-Linux systemd[1590]: Started Bluetooth OBEX service.
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1693]: [session uid=1000 pid=1693] Successfully activated service 'org.kde.KScreen'
Jun 16 17:07:03 Kalevala-Linux dbus-daemon[1291]: [system] Successfully activated service 'org.kde.kded.smart'
Jun 16 17:07:03 Kalevala-Linux kernel: Bluetooth: RFCOMM TTY layer initialized
Jun 16 17:07:03 Kalevala-Linux kernel: Bluetooth: RFCOMM socket layer initialized
Jun 16 17:07:03 Kalevala-Linux kernel: Bluetooth: RFCOMM ver 1.11
Jun 16 17:07:03 Kalevala-Linux org_kde_powerdevil[1993]: org.kde.powerdevil: org.kde.powerdevil.chargethresholdhelper.getthreshold fail>
Jun 16 17:07:03 Kalevala-Linux org_kde_powerdevil[1993]: org.kde.powerdevil: org.kde.powerdevil.backlighthelper.brightness failed
Jun 16 17:07:03 Kalevala-Linux kded5[1881]: Known activities: ("2733cd8d-ac2e-453e-8e17-f182d140a7b2")
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: Connected output 85 to CRTC 79
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: Connected output 86 to CRTC 80
Jun 16 17:07:03 Kalevala-Linux kded5[1881]: bluedevil: Bluetooth operational changed true
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper: Detected XRandR 1.6
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper: Event Base:  89
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper: Event Error:  147
Jun 16 17:07:03 Kalevala-Linux kded5[1881]: bluedevil: Agent registered
Jun 16 17:07:03 Kalevala-Linux kded5[1881]: bluedevil: Requested default Agent
Jun 16 17:07:03 Kalevala-Linux kded5[1881]: Registering ":1.27/StatusNotifierItem" to system tray
Jun 16 17:07:03 Kalevala-Linux kded5[1881]: kscreen.kded: PowerDevil SuspendSession action not available!
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: XRandR::setConfig
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: Requested screen size is QSize(3640, 1920)
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: Needed CRTCs:  2
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: Actions to perform: 
                                                                        Primary Output: false
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr:         Change Screen Size: true
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr:                 Old: QSize(4480, 1440) 
                                                                                Intermediate: QSize(4480, 1920) 
                                                                                New: QSize(3640, 1920)
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr:         Disable outputs: false
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr:         Change outputs: true
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr:                  (85, 86)
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr:         Enable outputs: false
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: RRSetScreenSize 
                                                                        DPI: 96 
                                                                        Size: QSize(4480, 1920) 
                                                                        SizeMM: QSize(1185, 508)
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: RRSetCrtcConfig (change output) 
                                                                        Output: 85 ( "DisplayPort-0" ) 
                                                                        CRTC: 79 
                                                                        Pos: QPoint(0,480) 
                                                                        Mode: 91 KScreen::Mode(Id: "91" , Size: QSize(2560, 1440) @ 74.>
                                                                        Rotation: KScreen::Output::None
Jun 16 17:07:03 Kalevala-Linux baloo_file[1996]: QDBusConnection: name 'org.freedesktop.UDisks2' had owner '' but we thought it was ':1>
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr:         Result:  0
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: XRandROutput 85 update 
                                                                        m_connected: 0 
                                                                        m_crtc XRandRCrtc(0x558e13271840) 
                                                                        CRTC: 79 
                                                                        MODE: 91 
                                                                        Connection: 0 
                                                                        Primary: true
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: RRSetCrtcConfig (change output) 
                                                                        Output: 86 ( "DisplayPort-1" ) 
                                                                        CRTC: 80 
                                                                        Pos: QPoint(2560,0) 
                                                                        Mode: 93 KScreen::Mode(Id: "93" , Size: QSize(1920, 1080) @ 60 >
                                                                        Rotation: KScreen::Output::Right
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr:         Result:  0
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: XRandROutput 86 update 
                                                                        m_connected: 0 
                                                                        m_crtc XRandRCrtc(0x558e13271a20) 
                                                                        CRTC: 80 
                                                                        MODE: 93 
                                                                        Connection: 0 
                                                                        Primary: false
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: RRSetScreenSize 
                                                                        DPI: 96 
                                                                        Size: QSize(3640, 1920) 
                                                                        SizeMM: QSize(963, 508)
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xrandr: XRandR::setConfig done!
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper: RRScreenChangeNotify
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper:         Window: 56623109
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper:         Root: 1737
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper:         Rotation:  "Rotate_0"
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper:         Size ID: 65535
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper:         Size:  4480 1920
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper:         SizeMM:  1185 508
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper: RRNotify_CrtcChange
Jun 16 17:07:03 Kalevala-Linux kscreen_backend_launcher[2324]: kscreen.xcb.helper:         CRTC:  79

thats ad far as I got


Do you have everything running through wireguard or a vpn or something like that? That “torguard-wg” process looks like it’s using a lot of CPU. Can you try turning that off/disabling it and see if it still happens?

UPDATE!!!
I have found the cause of the issue,
Though not a permanent solution.
Since this post was made I’ve been careful about what order, and how fast I turn my monitors back on. And it hadn’t happened for a while. Then one bleary-eyed morning, I wasn’t paying attention and just clicked both monitors on. And it happened, BUT I saw an error message, that I didn’t remember seeing before (it was probably buried under hundreds of other notifications).

desktop effects have been suspended by an application

and right there, the solution,

SHIFT+ALT+F12

That fixed it, I don’t have to reboot my computer, everything is working fine.

This doesn’t explain why it’s happening in the first place, or how to keep it from happening again, but it’s WAY better than rebooting, and gives an idea as to the actual problem.

Try System Settings -> Workspace Behavior -> Desktop Effects, click Defaults.