System Keeps Freezing When Running On Nvidia

Hello everyone, I’ve been having a problem with with Asus ROG Strix 513RC, which has an AMD CPU and RTX 3050 GPU.

I’ve tested the system with GNOME (both Wayland & X), and XFCE, and the problem still persists. I use envycontrol to switch between graphics mode and this issue occurs only on the nvidia mode, hybrid mode is fine but I simply can’t lauch anything using nvidia, it also means that I can’t use any external monitors since they need the dGPU.

The system either slows down to a halt or simply freezes, I might be able to switch to a tty, but most of the time I have to force a reboot.

Here’s the output of inxi -Fxxc0z: https://0x0.st/HRSi.txt
Here’s the output of journalctl -k -b -0: https://0x0.st/HRS-.txt

Have you checked if there is a newer UEFI Firmware (Bios) update? Your output for hardware only shows the amdgpu. Are you able to switch to nvidia and show inxi -Ga

I’ll investigate this, but why is this the case, it doesn’t really make any sense for me that a dGPU problem is a result of an old UEFI firmware.

EDIT: I just checked, there is no updates available to the UEFI, it’s up to date.

here’s the output: https://0x0.st/HRSP.txt
I’m only able to generate this from the tty, but I can’t login and use the desktop simply because it freezes after a few seconds.

At least it looks correct as far as drivers being installed and rendering properly on the Nvidia gpu.

The latest UEFI firmware is important for AMD processors. I’m not saying it’s the cause but i also don’t know that for sure. There’s no harm in updating it to see if it makes any difference. What happens with out envy control installed?

I’m not really sure, I never switched the graphics using any other tool? What can I use instead of envycontrol?

@pisceswolf96
Have you tried this package. rog-control-center Supposedly you can switch gpu also? :thinking:

Edit: There are also a few other tools. But i thought maybe because it’s an Asus ROG might try this?
Edit: You’d have to remove envy-control first.

@pisceswolf96
I think it’s this package.

https://asus-linux.org/

I changed it to dGPU but it still shows that it is using amd as the VGA controller when running lspci -v. So it doesn’t really seem to work

1 Like

Welcome to the forum!

I know you mentioned that there is same problem while using Wayland but I’d suggest to check and see how it works with the standard PRIME offload.
https://wiki.archlinux.org/title/NVIDIA_Optimus#Random_freezes_“(EE)_NVIDIA(GPU-0):_WAIT”

Are you sure this is the case? Quick googling shows you can choose which GPU can output signal to an external monitor.

1 Like

IIRC I think the HDMI port in this laptop is connected directly to the dGPU, but please correct me if I’m wrong.

Not exactly same model, just same Strix G15 family: according to Reddit (1 & 2 ), USB-C - discrete GPU, HDMI - integrated.

1 Like

https://www.reddit.com/r/GamingLaptops/comments/o49y67/asus_rog_strix_g15_g513_igpu_and_dgpu/

1 Like

Very interesting @ricklinux & @firefly, I tested the laptop by switching the graphics using the rog-control-center and it’s running fine on Nvidia & Hybrid graphic modes. I’ll test it with an external monitor tonight and see how it goes, if it works with no issues then it would means that the problem was entirely because of envycontrol and not the Nvidia drives.

Edit: Just tried the external monitor using both Hybrid & Nvidia graphics modes and it’s running smoothly, it seems that the problem is entirely with envycontrol and using rog-control-center to switch between graphics modes solves this.

Thank you both @ricklinux & @firefly for your help, much appreciated.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.