System is half broken after forced a shut down while updating

Hi. My PC froze while updating and I decided to shut down it. This lead to a broken system. I have managed to reinstall every single package on the system and now I can get into the system, but there are 3 failed units displayed while running systemctl as root (it fails when I run the command with my normal user, by the way). I know two of them are dbus-broker.service and avahi-daemon.service. I don’t know the third one. I would provide logs and everything, but the system can’t connect to the internet (I think because avahi-daemon.service is not running since that’s related to DNS somehow?) and I also don’t really know how to do it. Any help will be appreciated. Thanks.

If that’s regarding the logs, you can see here
https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/

Thanks. It seems that most of these don’t work from chroot, though. I don’t have internet on the system, so I guess I will put everything into files and upload them here manually. Be right back…

1 Like

have you tried updating your system inside chroot?
Reinstalling your kernels, rebuilding your kernel images?

1 Like

Here are some logs. I hope these ones are good…

Summary

Using the EOS Log Tool
https://dpaste.org/YF7S5

Running systemctl list-units
https://dpaste.org/EJ8Ft

Yes. I’ve done that. I’ve reinstalled all of the packages on my system in chroot and in the system itself and I let it do its thing. I could try again, I suppose.

1 Like

Perhaps run a filesystem check on your system partition(s).
They would need to be unmounted.
You could use the partition manager included in the live iso to perform this task.

1 Like

Let me do that. I have just ran # reinstall-kernels and # dracut-rebuild and nothing changed.

EDIT: Nothing changed after checking the filesystem through the LiveISO.

1 Like

This may be a long shot but could you switch from dbus-broker-units to dbus-daemon-units in chroot to see if it makes any difference?

1 Like

Sure, but how do I do that…? :sweat_smile:

Just install dbus-daemon-units in chroot. It should ask you to replace the other. Accept the replacement.

1 Like

That worked! Thanks a ton!

2 Likes

Okay, nevermind. While the system now is more functional, Plasmashell doesn’t not want to start, returning this when ran in the terminal: kf.coreaddons: error parsing "/usr/share/plasma/shells/org.kde.plasma.desktop//metadata.json" "illegal value"

I will try to fix it myself. Fixed by running # pacman -S --overwrite="*" plasma. I put the overwrite flag because pacman complained about files already existing.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.