System froze on update. Can only boot into a btrfs snapshot. Update there not working

I believe I am yet another person suffering form KDE6 + Nvidia + Wayland.

I use grub.

Ran regular update, system froze, then when I restarted, the normal option for starting my system in grub was gone - only btrfs snapshots. Chose the one before the update. It did boot, but when I tried updating the system, the update runs, but I get the following:

First, on pre-transaction hooks:

(1/1) Performing snapper pre snapshots for the following configurations...
IO Error (subvolume is not a btrfs subvolume)

Then, after the updating is done, on post-transaction hooks:

(3/4) Generating GRUB config to let grub-btrfs detect new snapshots...
/usr/bin/grub-probe: error: failed to get canonical path of `rootfs'.
error: command failed to execute correctly
(4/4) Performing snapper post snapshots for the following configurations...
Invalid snapshot '--type'.

The result being that when I restart, I still don’t have the normal option for starting my system with grub, and no new snapshots have appeared. So basically nothing has changed.

I then did arch-chroot from a live-usb. Reinstalled grub, which has fixed similar problems in the past, but nothing changed.

Finally, I stumbled upon this topic on the EndeavourOS forums. Went into arch-chroot again, ran:

paccheck --list-broken --md5sum

which showed

eos-plasma-sddm-config
lsb-relsease

I reinstalled them and then reinstalled the kernel using

pacman -S linux-zen

(as I use zen). New snapshots were created. I closed arch-chroot and rebooted.

Now, I do get an option in grub for the standard system (not just snapshots anymore), but when I select it, I reach something like

Reached target Graphical Interface

and nothing happens after that (I believe the next thing that is to happen is to have the login screen where I type my credentials, which I believe is SDDM for me). Also interestingly, I get

[Failed] Starting WPA supplicant

or something like that. I have never had any [Failed] before.

I did some searching on the forum, but saw people with either problems that looked more serious, or with very extreme solutions - like reinstalling everything. Given that I can boot into a snapshot from just before the update, I hope I won’t have to do anything like that. Thank you.

I faced same issue. Reinstalled. I updated the system today and same issue. Even worst it’s blinking, cannot change the tty.

Can you try this? You might be able to get it up and running with out reinstalling.

1 Like

Isn’t that a systemd boot related command. I am using grub. Is that going to matter?

Which command?

reinstall-kernels

I can boot past the BIOS (which is what the problem of that person seems to be). It is just that the pre-starting procedure (I don’t know what the thing between selecting an entry in the grub menu and being asked for your password is called) gets stuck on

Reached target Graphical Interface

I can also start up and use a btrfs snapshot from just before the update. That works all fine, apart from not being able to update from the snapshot, as I have described in my first post.

I did try running an update from within arch-chroot, but that only updated 2 packages (not the 40 that the update that my laptop froze on was trying to make) and rebooting after that didn’t change anything. This is what seems to happen in the post you have listed and the command that helps them after that is reinstall-kernels, but I don’t think I can run that on grub. I did do pacman -S linux-zen which finished, but didn’t solve my problem.

Can you post the results of inxi -Fxxc0z | eos-sendlog?

Here it is

The stem of your problem is nvidia 550.xx drivers.

Device-2: NVIDIA AD104M [GeForce RTX 4080 Max-Q / Mobile] vendor: Dell
    driver: nvidia v: 550.76 arch: Lovelace pcie: speed: 5 GT/s lanes: 8 ports:
    active: none off: DP-3 empty: DP-1, DP-2, HDMI-A-1, eDP-1 bus-ID: 01:00.0
    chip-ID: 10de:27e0

This is a continuous problem (it’s not us it’s them). Try the solutions listed here.

I also think it is something to do with these drivers. That is why I was excited that there is an update to the drivers, when I tried updating. However, my current problem is that I can’t boot into my system normally, so I can’t really make any of the changes suggest in that thread.

I first need to figure out how to get past

Reached target Graphical Interface

Do you have any idea about that?

You should not try updating your system or performing any other system maintenance when booted to a Btrfs snapshot. Think of it like a temporary environment, kind of like booting to the ISO. Really you shouldn’t do much of anything when booted to a Btrfs snapshot except restore the snapshot, then reboot to the “real” system (which has now been restored to the state of the Btrfs snapshot) and do your work from there.

Yes, the reinstall-kernels script is specifically appropriate for systemd-boot setups because it creates or updates the boot entries in addition to regenerating the initrds and so on. With Grub, you can just reinstall the kernels with the package manager as you have done.

Even better, try a different kernel and see if you get a different result. The LTS kernel, for example, is a different kernel version; if you are up against a kernel regression or similar, the LTS kernel may still work.

Set up the arch-chroot again, then install:

pacman -Syu linux-lts linux-lts-headers

Exit the chroot, reboot, and choose the LTS kernel from the Grub menu to see if you have any better luck.

1 Like

Ohh, I guess I misunderstood the process. I thought that I should first update on the snapshot and then restore it.

Anyway, I tried your suggestion

pacman -Syu linux-lts linux-lts-headers

from chroot. When I rebooted, I just got a black screen after the grub menu.

Finally, I booted back into the working snapshot and restored it. It works now.

I then redid the update in random parts and it all worked. This nvidia 550.xx driver basically leads to random freezes, so I thought that if I split the updating procedure in parts, I will always have a snapshot to get back to. I hope they fix it soon.

Nice one, glad to hear it. :+1:

That is an unusual fix for sure. It sounds like something became broken which was not getting addressed by the update tools. Maybe reinstalling all packages would have fixed it, although honestly restoring a snapshot and building it back up from there seems less clumsy.

Me too. :smiley:

I don’t know why I didn’t think of first restoring the snapshot and then updating rather than trying it the other way around. Thank you for the input, it triggered the correct neurons :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.