System freezes on bootup screen after updating OS

Hi. I am noticing a pattern of system freezing that I want to bring attention to. A handful of times now, I have had my system freeze during the boot up screen precisely after entering my drive encryption password. I am also able to predict that this will happen because each time it does happen, it’s also not asking me which kernel I want to load into, which is strange enough. This is happening from what I notice randomly after I update my system and reboot right away. To be clear, the most recent freeze which happened just before I made this post was a voluntary reboot after upgrading. What I mean by voluntary is that the system did not complete an update that it recommends I reboot after. The only way out of it is by doing a hard power off from my physical computer tower.

I do not understand the circumstances in which this occurred, nor do I understand your course of action afterwards. The system did not complete an update but it wanted you to reboot? How exactly did the system fail to complete the update? What drove you to press the power button to force shutdown? Did the system freeze during the update? I thought the system only freezes during the boot-up process like you mentioned earlier in the paragraph.

Huh?? So did you successfully reboot or not? I’m so confused. Force shutdown with the power button does not count as a reboot.

The fact that the system failed to complete the update yet notified you to reboot makes no sense to me. The reboot notification script is triggered in a pacman hook post-transaction, which means if the notification was sent out, the update had already completed. This contradicts the fact that you had to press the power button to shut down. Please clarify.

Okay. So the most recent freeze occurred at the boot up screen, so you were forced to press the power button when the system was still booting up (it froze). But after you shut down and boot again, the system managed to boot successfully. Did I understand correctly?

It would also help if you post some journal entries and the output of dmesg after the freeze occurs.

I just re-read my message, and I am not sure what I was unclear on, but I will try to explain again.

The freezing is only happening on the boot up screen, where you enter your encryption drive password. If you set up an encryption password for your drive, then you will be familiar with this prompt each time you reboot your system.

I am also stating that this freezing only happens after I run a system update and reboot immediately after. All I was trying to articulate is that i sometimes reboot after an update even if the OS does not recommend I need to reboot.

It would be much better if you were to provide your hardware info first. Then logs and error messaging output from journals or dmesg as has been asked for and then an explanation of the issue. You are obviously running luks but we have no idea about anything else such as what desktop you have installed, the file system and partitioning you are using, your hardware etc etc. We don’t know whether you are using grub or systemd-boot or rEFInd. Just reporting that the system freezes after updating isn’t very helpful.

1 Like

When I first saw this, the thing that immediately came to mind was that maybe GRUB_TIMEOUT_STYLE was set to something other than “menu”. Perhaps the bootloader is just waiting for the grub timeout to run down before booting into the default kernel, but since nothing was shown on the screen, it looked like the system froze. However, I didn’t want to jump to conclusion because you didn’t mention what bootloader you’re using.

Are you able to trace the last update before this behavior started?

Fair enough. I attached my system info below. As far as logs or any other info goes, please direct me on how to provide that, as this will be my first time.

Note: I use systemd-boot (default option when installing)

It is definitely freezing. I once waited almost 10 mins before giving up and forcing a hard restart.

Unfortunately, I did not keep track of that. It’s happened several times now over many non-related updates. I don’t think it’s attached to any specific update.

This is not what we mean by hardware logs. We would like the full hardware output. We would like logs such as a dmesg log and a boot log using journalctl. It is also easy to look at the last updates you did when the problem started happening. they are in /var/log/pacman.log

Examples of how you provide that information is provided in the wiki.

I understand, and thanks for sharing that link.

I tried the first command it’s giving me for the hardware log in konsole, and I am unsure what the next step is? Where’s the log? :point_down:t3:

You just post the url.

Edit: The url has the uploaded log from the command.

This looks like an Intel NUC system with an Arc 770. Looks like it also has onboard graphics? Looks like it’s running on the Intel driver. xf86-video-intel As far as i know the Arc Gpu should run on a kernel module. Maybe try uninstalling the Intel driver and see how it works.

Correct. Intel NUC with both ARC GPU and an onboard. As far as I can tell, the ARC GPU driver is installed and working as intended. I say that because it runs steam games as it should. Whatever driver is installed did so on its own when I installed EnOS.

Note: I switched from a different NUC PC to this one about a month ago. The previous one was an Nvidia GPU that had zero issues. This INTEL GPU one has this freezing issue and also very often does not suspend the screen at the set time. Not sure if it’s related to the same problem, but I thought I’d mention it.

How do I uninstall the driver and is that going to prevent me from gaming, doing video related tasks, etc?

You can try removing xf86-video-intel as i said.

I will try it and report back, but just to be clear, is this removing the onboard graphics driver or the ARC driver?

It is just removing the Intel driver.

sudo pacman -R xf86-video-intel

Yes … I know! Was giving the OP the opportunity to learn. :wink:

1 Like

Shoot. I didn’t mean to reply to you, @ricklinux

My apologies. I meant to reply to the OP.

No problem with that. I do it sometimes replying to myself. :rofl:

this does not need the Xorg intel driver package and make use of the in kernel shipped modesetting intel gpu driver.

We had to remove thius already from beeing used for the ISO to be able to boot on ARC GPUs.
ISO will detect if GPU needs xf86-video-intel and install this on the run… default is using the in kernel modesetting intel gpu drivers.