System freezes after switching on from Suspend session

System Configuration:

  1. Acer Nitro 5 AN515-52, 8 GB Ram, Intel UHD 630 Graphics Card, NVIDIA Geforce GTX 1050Ti 4 GB graphics card.
  2. Acer external monitor.

Whenever I switch on my laptop from suspended session, it either freezes giving black screen on external monitor, or if by any chance both my displays are working and I am able to login, my home screen stays freezed, although I am able to run the applications that are available on the screen.

Kernel Version: 6.6.10-arch1-1 (64-bit)
KDE Plasma Version: 5.27.10
Graphics Platform: X11

Things I have tried:
sudo systemctl enable nvidia-suspend.service
sudo systemctl enable nvidia-resume.service

Hi, and welcome to EnOS community :enos_flag:

When the freeze happens, can you switch to some TTY (i. e. by pressing Ctrl+Alt+F5)?

Have you enabled preserve video memory after suspend? Check out the arch wiki for details https://wiki.archlinux.org/title/NVIDIA/Tips_and_tricks#Preserve_video_memory_after_suspend

Also, it would help if you can show us your journal. After a reboot from freeze, run this and copy the url

sudo journalctl -b -1 --no-hostname | eos-sendlog

https://0x0.st/HIRY.txt

I was able to switch to the TTY using f5.

I haven’t enabled preserve video memory after suspend. Will give it a try.

@jake99 I tried what was given in link you shared.
Created a file /etc/modprobe.d/nvidia-power-management.conf and added
options nvidia NVreg_PreserveVideoMemoryAllocations=1 NVreg_TemporaryFilePath=/var/tmp

Also I did, sudo systemctl disable nvidia-resume.service but still getting the same results.
https://0x0.st/HI78.txt

Took a quick look at the last log you sent. Lots of weird stuff going on.

KScreen (xrandr) backend is going crazy after suspend. First it wakes up your external HDMI output, but then, when it tries to wake up eDP output on built-in screen, HDMI output gets disabled.

After eDP-1 is up and enabled, it frantically tries to get HDMI up again, it manages to do it, but then HDMI gets disabled/enabled again, and in the meantime it cycles between setting primary/secondary screen between eDP and HDMI. Finally, xcb segfaults and crashes.

Most likely a driver bug.

Can you provide your Xorg log and dmesg? Also, are you by any chance using reverse PRIME?

dmesg.pdf (81.1 KB)
Xorg.0.pdf (66.8 KB)

I am not using reverse PRIME but I read it on some other forum that the new hardware and drivers are automatically using reverse PRIME.

Please don’t send PDFs. Copy and paste the text here or use eos-sendlog

eos-sendlog < /var/log/Xorg.0.log
sudo dmesg | eos-sendlog

Xorg Log: https://0x0.st/H0WM.txt
dmesg: https://0x0.st/H0Wu.txt

@jake99 Uploaded Xorg and dmesg logs.