System broke down after running a full system update

I just ran sudo pacman -Syu and then I restarted the system but then I get the following screen:


My system had slowed down quite noticeable with Firefox and lutris and file manager not responding frequently which made me think this was an issue with gnome so I ran a full system update.
Help is much appreciated

That looks nasty :frowning:

Boot of the install media, chroot in and try the update again:

sudo pacman -Syu

Can you see the home directory? (from the install media).

1 Like

You’ve made a number of interesting leaps there… I have no idea how you linked those things together as related…

However, the fact one of your partitions has “gone missing” is an issue. While you have the install media booted you will want to check your partition list (e.g. lsblk -f) and run a check (fsck), and then make sure the UUIDs match your installation’s /etc/fstab.

3 Likes

If you have not changed your /etc/fstab this UUID error is most likely pointing to a hardware issue with our /home partition. Your findings about a previously hanging file manager and hanging firefox support that. You want to check that.

My hard drive had 42 bad sectors the last time I checked but also I followed this thread here:
https://www.google.com/url?sa=t&source=web&rct=j&url=https://bbs.archlinux.org/viewtopic.php%3Fid%3D223633&ved=2ahUKEwjLxKiFzaLtAhXA7nMBHWvjBuoQFjABegQIBBAB&usg=AOvVaw1MW_FrqwAJxu2Su-H-dCiF
And at the very end of the page he mentioned running -fsck manually which is what I did and I pressed yes on every prompt and the issue was fixed,for the most part as I could at least boot and everything was normal.Except wine ran into some issues so I used tineshift and downgraded to the previous stable version.Everything works fine for now.
Anything I should look out for since I mindlessly typed yes whenever prompted?

You are indeed right about me making leaps,I was solution hunting this problem and somewhere I found the same issue and the person just tinkered a bit with their DE and all was good.Since their issue was really close to mine,I assumed the same to be true.And I should say that after I ran fsck manually and booted into the system,that issue of unresponsiveness did disappear, although the update caused more problems than solve lol.

If running an fsck resolved an issue with your filesystem then that indicates you had filesystem corruption (possibly caused by an unclean shutdown or hard poweroff).

This is, again, unrelated to a package update.

Missing files.

You might want to consider making (and maintaining) a backup of important files so that you don’t suffer as a result of disk failure.

You could also run a disk health check using smartctl (part of smartmontools) to find out whether the disk itself is failing.

You think you can repair defective hardware with some magic commands?

Replace the HDD and that immediately!

3 Likes

Is not just that. If the fsck corrected the meta data but not the data you end up with files with 0 length.

But anyways, if the root cause of the filesystem corruption is a hardware defect you should better think about replacing the device and restoring from backup.

2 Likes

Common sense would dictate replacing the drive. Commands don’t magically repair the drive as @axt said. It is possible that file system errors can be repaired but most hard drive bad sectors are usually marked not be used. The drive will still be bad.

2 Likes

_atmosfear, every HDD/SSD has a reserve from which defective sectors are logically replaced. This is called mapping. The user can’t access them, also not even the operating system, only the logic of the disk can it.

If tools show defective sectors, it means that the reserve is used up. The drive is rapidly approaching its death.

1 Like

I agree with you. Myself, if a hard drive was showing any bad sectors i would be replacing it. Hard drives are not very expensive anymore.

1 Like

Today on Black Friday there will be various offers :wink:

And of course SSD instead of HDD.

I stay away from Black Friday! But online …yes!

2 Likes

Better off finding what you want or want to give earlier in the year, cause you will always at some point during the year beat the Black Friday “deals”.

1 Like