System and Live Image not working on AMD GPU

It shows right here that it’s not loading any driver for your Gpu.

  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Sapphire Nitro+
    driver: N/A arch: GCN-4 code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 29:00.0 chip-ID: 1002:67df class-ID: 0300
  Device-2: Creative Live! Cam Chat HD [VF0700] type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 1-3:3 chip-ID: 041e:4097
    class-ID: 0300
  Display: server: driver: N/A tty: 128x48
  API: OpenGL Message: GL data unavailable in console for root.

I run an RX 590 and no issues. It’s supposed to run on amdgpu kernel module.

Edit: Can you run this again as there is a typo on the other one. Seems to be missing some info.

inxi -Faz | eos-sendlog

Edit: I see no reason why the live ISO would not be loading with this hardware. I would download the latest ISO and create it on another machine with Windows using etcher.

Flashed the ISO again on my win 10 with balena etcher. it does not boot on my machine. the output of the command you send me is in the thread above. Ive corrected the typo myself

You said you updated the UEFI firmware? That’s why i wanted you to show the output. Not sure why you have this issue. Is your graphics card a RX590? That’s what I’m running on.

Edit: How is the monitor hook up?

Since you have used some ISO image successfully to initially install, that one should still work. Use that image (or another old one) to test if it is booting, to exclude a hardware change/problem.

  • If no image is booting (while it was previously), the issue is not with the software.
  • If you can boot to some (any) Live ISO image, then you can troubleshoot from there (provide info/feedback to get suggestions, if you think so).

It makes no sense to me why it doesn’t boot? Did the OP check the settings in UEFI Bios if they updated it because secure boot may get set on as default setting.

module_blacklist=nvidia,nvidia_modeset,nvidia_uvm,nvidia_drm nomodeset nvme_load=yes

this is not the default boot entry it is a fallback nomodeset boot entry…

@yugimuo may take the wrong entry to boot but with this AMD GPU will not work properly.
use default entry.



Like I’ve been saying all along i did not see ANY reason why the hardware would not boot on the live ISO. This has been mentioned…

Edit: I think we need AI on the installer. :rofl:

systemd boot as its best

IIUC, OP created a USB installer, using the latest EnOS version. I supposed that they originally used an older ISO version (successfully), while the latest was failing (for whatever possible reason).

I/we wait OP to try an older ISO version.

We operate asynchronously :clock1030: so we can only wait for OP feedback :person_shrugging: .

kernel regression ?

@yugimuo yoiu can try this rebuild ISO here … it is the same as released but rebuilded with latest packages:

So I tried the image you send me. It does not boot with the UEFI Default option. The CPU fan spins up for at second and thats it. Nomodeset is really the only thing that at least produces tty. As strange as it sounds. Can someone send me an older version of endavouros. I really think this update is not working on my PC.

Are you able to access the ISO from here?

Yes I am Downloading it right now. An Interesting discovery I made is the difference between the Xorg logs when I boot into the nomodeset image and install xf86-video-fbdev. This is the only way to start Xserver at the moment on liveusb.
With Fbdev installed:
without it installed

It probably has to do with your motherboard. Its a B450M correct? I remember some issue before where it is not switching on boot from vga or something so it gets no output.

I think you need to try the following kernel parameters to boot on possibly.

iommu=off acpi=off

Edit: Try the previous ISO and let me know as i can give you a link for older ones also. It just would be nice to figure out what kernel parameter you need for that hardware.

Edit2: If the above kernel parameters don’t work try this one


ok so with the parameters given above it boots into xorg. Thats good. Tried it on my live system but it does not boot into xorg. I am guessing I broke some things in Xorg while trying to get to the issue. Is there a Way to factory reset Xorg? and can I hardcode the kernel parameters

Did you try amdgpu.dc=0 on current live ISO itself? Does it boot?

Edit: When i say boot. Does it boot on the live ISO to the desktop installer?

yes it does boot. I added all parameters but I will narrow it down to amdgpu.dc=0
and yes It does boot to the installer live iso
I thing the last problem is that I broke Xserver in the process of trying to fix some errors

So is your install with grub or systemd boot?

I’m not following you on this? What do you mean? It doesn’t boot on the installed system?


There is no xorg file using amdgpu in /etc/X11/xorg.conf.d/
In /usr/share/X11/xorg.conf.d/ there are two files for AMD related configuration on my system using an RX 590 graphics card.

You need the kernel parameter amdgpu.dc=0 in /etc/default/grub if you installed with grub. and then you have to update grub also in order for it to keep this setting after adding it.

sudo grub-mkconfig -o /boot/grub/grub.cfg

If you installed with systemd boot then it has to be added differently.


Section "OutputClass"
	Identifier "AMDgpu"
	MatchDriver "amdgpu"
	Driver "amdgpu"


Section "OutputClass"
	Identifier "Radeon"
	MatchDriver "radeon"
	Driver "radeon"

There are some other .conf files also in the same folder but these are the only two related to the graphics card and amdgpu which is what it should be using.

Yes I have added the kernel Parameter to grub and it worked. I have also copied the conf files to /etc/X11/xorg.conf.d/ and added the 10-radeon.conf mauallly. However xinit still gives up when I do startx. even after restart. Maybe I have modified something else? there is no log file from XServer. Xinit gives up after line 2 of /etc/xinit/xserverrc

it says /etc/X11/xinit/xserverrc: line 2 /usr/bin/x: success
xinit: giving up
xinit: unable to connect to X server: connection refused
xinit: server error