System and Live Image not working on AMD GPU

I am having problems with my system after updating. It does not boot correctly and the screen turns black mid process. Probably is an Xserver Problem. Logs show missing Drivers if I read it correctly. Tried to rescue with a fresh Live USB Image. It also does not want to boot into Xserver.
Xorg Log shows.

Failed to load module fbdev and vesa.
/dev/dri/card0 no such file or directory

This is bad news… :face_with_head_bandage:

I assume you can boot to TTY. If so, check this command output:

ls -Rl /dev/dri

If it’s a Desktop PC, try reseating your (external) GPU.

I see in the logs in kernel parameters, that you boot a non-nvidia option, but also includes nomodeset kernel parameter. I am sure ISO devs know their toys, but AFAIK AMDgpu cannot boot with nomodeset :thinking: .

I guess I am going to learn something new from this… :slightly_smiling_face:

I am quiet bad with understanding what you say. can I rescue this system?

According to the log, I don’t see Xorg trying to load amdgpu driver, which is the right driver for your card (I have the RX 570).

You should check if xf86-video-amdgpu package is installed.

Package is Installed. Maybe it is not loaded correctly? could I check that somehow.
ls -Rl /dev/dri is 0

Maybe just as a sidenote. I run dual boot and Windows works just fine

Update. Looks like an issue with Fbdev. Fbdev seems to not be installed in the current update. Got working xserver on liveusb if I installed fbdev. However on my real system fbdev is installed and it still does not work?

Remove “nomodeset” from kernel command line. AMD drivers don’t work with that set.


You are correct nomodest cannot be used or it wont boot. I have the RX590 and no issues ever. Not with updating or installing or anything.

1 Like

I don’t know.

For a start, do as suggested. Then we may have more clues, that might help us understand better what happens.

…meaning, if you can edit kernel parameters in a boot menu, before hitting Enter for booting, edit, and delete the word nomedeset. Then boot.

tried to edit the kernel parameters. It does not want to work with nomodeset removed. Cannot spawn tty if I remove it. with nomodeset I at least can get into tty of the liveusb. ls -Rl /dev/dri gets total .

This means you have no video card. :scream:

Have you posted system info?

inxi Faz | eos-sendlog
1 Like

First of all your motherboard has the original UEFI Bios that it came out with at manufacture. There are 12 newer UEFI Firmware (Bios) updates. It would be wise to update to the latest which is

7A38vBG dated 2022-08-08


Updated it

Can you get the packages of the last update?

Maybe confirm you have fastboot and hibernation disabled in WinOS and do a proper/full power off.

Can you check booting an older ISO, or an Archlinux ISO? If a package update started this, then an older ISO (EnOS/Archlinux) that can boot properly must exist.

Feedback? :question:

update did nothing. Im gonna check for hibernation and fastboot. Also gonna try an older ISO

1 Like

Are able to boot on the live ISO? Have you downloaded the current ISO and created a new live usb? It does not make any sense to me what so ever that it won’t boot on the installed system and also doesn’t boot on the live ISO.

Edit: How are you creating the live ISO? On Windows? What tool?

I created the ISO with the burn Image tool of endavouros thats installed on my laptop. And well the live usb boots but Xserver crashes too. I at least can get into tty which is not possible on my main system. And I can get Xserver to run on the Live Usb after installing xf86-video-fbdev. Wrong display ratio but it still work. The same Approach does not work on my main system.
Maybe I broke it even further while trying to repair it?
is there some way to reinstall Xserver to stock configuration so that I can try with the USB workaround?