Switching from Nvidia to Amd Gpu

I recently bought a new amd gpu and I want to switch from my current Nvidia gpu to the amd gpu, I tried to do it and it just sits on that black screen with the text on it right before it usually would load up into plasma, So I tried installing xf86-video-amdgpu and rebooted it, still same thing. Has anyone done this before I am switching to a Rx 6500 xt.

Did you uninstall the Nvidia before you switched out the card? Or were you using the Nouveau open source drivers on the Nvidia? You definitely need the xf86-video-amdgpu

Edit: If you can boot up and switch to a TTY and log in as root and uninstall nvidia drivers?

You don’t need to uninstall the nvidia drivers but you do need to make sure you don’t have any nvidia-specific settings in your x11 config.

Other than that, there should be nothing to it.

Wouldn’t uninstalling the Nvidia drivers remove the nvidia specific settings in x11 config?

Not unless they are drop-ins installed by the package. If you have done any config changes yourself or used the nvidia settings tool to make changes you need to remove them yourself.

1 Like

Go to TTY and check your settings

grep -i cmdline /etc/default/grub
grep -v ^# /etc/mkinitcpio.conf | grep .
ls /etc/X11/xorg.conf.d

And errors

journalctl -b -p3
systemctl --failed
grep -E " failed| error|Time" /var/log/Xorg.0.log

if you used the nvidia driver GUI tool, you have a /etc/X11/xorg.conf that tries to force-load the no longer working/existing Nvidia driver on the AMD card, which leads to a black screen.
Look into that file and remove all references to nvidia (or if it contains only GPU stuff, delete it)

1 Like

Sadly I couldnt get plasma to load so I had to clean reinstall EOS plasma with no nvidia drivers. That worked. Alls good though I really needed to do it anyway to switch ext4 to btrfs, Now I got timeshift snapshots on grub, woo hoo!, thanks for all the help everyone!