Switched system over to LVM, now lightdm doesn't boot

I switched my system, which was on a LUKS encrypted partition, to a LUKS encrypted partition on LVM, changing all of the appropriate files and reinstalling GRUB to do so. Now the system boots fine, and gets to the point where systemd is starting services, but now lightdm doesn’t start. When I run systemctl status lightdm, it says:

lightdm.service: Start request repeated too quickly.
lightdm.service: Failed with result ‘exit-code’.
Failed to start Light Display Manager.

I have also tried reinstalling lightdm, but nothing changed. This is on Endeavour OS XFCE.

Can you post the contents of /etc/lightdm/lightdm.conf?

I think I found the problem. I booted it up again to upload the file, and got an error from some program about not having enough space. So then I went into a live environment and expanded the LV and filesystem and rebooted, and lightdm started working again. Thanks for trying to help though!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.