Sway Edition - General Conversation!

OK, now I see the problem, my bad. I’ll fix it as soon as possible.

There was a problem? :upside_down_face: Thank you!

Another change round line 108, same function:

    107     test -n "$pic" || DIE "no picture!"
    108     if [ -z "$DE" ] ; then
    109         [ -x /usr/bin/swaybg ] || DIE "no DE!"
    110     fi

So I copy this in? Like this or under case "$DE" in and do I remove the thing before?

WallpaperSetCommon() {
    # Assume:
    #    - $pic is the picture file name
    #    - $DE is the desktop environment

    test -n "$pic" || DIE "no picture!"
    test -n "$DE"  || DIE "no DE!"
    test -n "$pic" || DIE "no picture!"
    if [ -z "$DE" ] ; then
    [ -x /usr/bin/swaybg ] || DIE "no DE!"
    fi

    case "$DE" in
        BUDGIE)
            AssertPicture endeavouros_budgie.png
            gsettings set org.gnome.desktop.background picture-uri "$pic"
            ;;

Sorry! I’m not really helping. This shows the same thing. “NO DE”

You have simply too many lines there… :wink:
Make it like this:

WallpaperSetCommon() {
    # Assume:
    #    - $pic is the picture file name
    #    - $DE is the desktop environment

    test -n "$pic" || DIE "no picture!"
    if [ -z "$DE" ] ; then
        [ -x /usr/bin/swaybg ] || DIE "no DE!"
    fi

    case "$DE" in
        BUDGIE)

@manuel do you that file vanilla…I messed up terribly :tired_face:

1 Like

No problem! It is so easy to make mistakes. :wink:

By the way, I already released new eos-bash-shared 1.5.22-1.
Please test that and report! :sweat_smile:

1 Like

It worked! I mean the actual script worked! But it can’t find the image


[swaybg-1.0/background-image.c:30] Failed to load background image (Failed to open file “DEFAULT”: No such file or directory).
2021-02-02 11:44:50 - [swaybg-1.0/main.c:438] Failed to load image: DEFAULT
2021-02-02 11:44:50 - [swaybg-1.0/main.c:295] Could not find config for output HDMI-A-1 (Unknown 2369M AFQG59A000384)
2021-02-02 11:44:50 - [swaybg-1.0/main.c:295] Could not find config for output eDP-1 (Unknown 0x057D 0x00000000)
1 Like

CTRL+d

meta+q (defualt i3/sway keybinding)

I will do this in a little while. better yet let’s set something up like EOS i3 so that you can hit a keyboard combo and pull up a text file with all this information like EOS i3.

Gotcha on it!

1 Like

I did a freash install last night. Grub, lightdm, and the desktop all have the new wallpaers/styles. Looks nice!

1 Like

Right, my bad again, sorry about that! But we are getting there!
I’ll fix this soon.

1 Like

Remote testing can be very slow… :wink:

But now I updated eos-bash-shared to 1.5.23-1. Interesting to see if this helps (it should!), because I can’t test it here…

2 Likes

I can do a metal install in a couple of hours if needed.

It worked or at leas it didn’t show any errors! But the wallpaper doesnt set

Setting desktop wallpaper /usr/share/endeavouros/backgrounds/endeavouros-wallpaper.png for '' ...
2021-02-02 12:17:34 - [swaybg-1.0/main.c:299] Found config * for output HDMI-A-1 (Unknown 2369M AFQG59A000384)
2021-02-02 12:17:34 - [swaybg-1.0/main.c:299] Found config * for output eDP-1 (Unknown 0x057D 0x00000000)

I need to study swaybg slightly better because I’m sure you’ve not done anything wrong.

Then it must be something in the swaybg command or options.

Could you try command

swaybg -i /usr/share/endeavouros/backgrounds/endeavouros-wallpaper.png

does that work? Or is just exec missing?

Swaybg won’t set. Unless you first kill the existing process then set it.(I think) I have no idea why. I will kill swaybg and try again

1 Like

Yep that’s the problem. You’ll have to kill the existing process in the script then set the wallpaper

1 Like

Which process? Which command did you use to kill it?

1 Like

killall swaybg

1 Like