Suspending/Sleeping locks Wi-Fi

Hi, I’ve been using EndeavourOS for almost 2 months and I keep having this issue where whenever I suspend or sleep my system and then wake it up. It locks my Wi-Fi(I can’t turn it on) and I can never enable it unless I reboot. This does not happen on windows, I’ve slept my system on windows many times and it never had this weird issue.

I did found a solution(kind of), however its annoying. What I basically did was hibernate my system and it actually didn’t lock my Wi-Fi like it did whenever I suspend my system. I’m extremely annoyed so I wanted to ask if there was a way to fix this, if you know an answer to it please help and thanks. I am also happy to provide more details.

Hardware Info: https://clbin.com/kR3wb

Hi and welcome to EnOS’ community @Daconday !

Please read the article linked to below and post some info and logs. This will help those who are able to help to have some ideas about your system and the issue you are having.

1 Like

All right I’ll check it out

I got the hardware logs, however I didn’t know how to get the journalctl logs.

It’s described in the article linked to above.

After you wake your machine up from suspension, have a look at:

Journalctl | tail -n 200

to see if you see something relevant related the wifi connection not coming back. Change the number to see more or less lines.

Apologies for taking this long, but here is the log https://clbin.com/xGdpa

1 Like

Thanks for posting the logs. I have glanced through it and I see certain stuff related to NetworkManager but honestly troubleshooting this is above my current linux-knowledge.

I am sure more advanced user will have a look and chime in to assist you.

By the way, what is the output of the following command when the system wakes up after suspension:

rfkill list

?

It’s fine I’ll wait for a more advanced user, but anyways here is the rfkill list command output when I wake up from suspension.

1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes

The weird thing is that this NEVER happens on Windows 10, and also I found out that airplane mode is on after suspension and can’t be turned off which might also be why I can’t turn on my Wi-Fi. I also tried clicking my airplane mode key on my laptop, but it wouldn’t work after waking up a suspension. Checked everywhere for a physical button too, but didn’t find any.

1 Like

Not sure if this works for Hard Block, but you could try:

sudo rfkill unblock all

Sadly it didn’t work

1 Like

I am not finding much about this issue. Here are some stuff for you to get on your own research about the problem:

https://wiki.archlinux.org/index.php?title=Special:Search&search=hard+blocked

:warning:
If you are going to make any changes to any configuration files on your system, make sure to make a backup copy of it first. Also, keep your Live USB installer near at hand in case you would need to do some repair work from the live session

Good Luck!

All right I’ll try researching, but weirdly enough this happens on EVERY distro(I believe). This happened on the first distro I used which was Ubuntu then I switched to Manjaro and then EndeavourOS and the problem still pursues. Anyways thanks for the good luck, I’ll need it.

1 Like

Thanks!!!

The askubuntu.com forum or whatever actually fixed it! It totally reconnects to wireless internet automatically whenever it wakes from suspension, can’t thank you enough I’ve had this issue since I’ve used started using Linux.

1 Like

You are welcome!
Great! I am really glad you got it sorted out!

Please consider to check the box “solution” for appropriate post in the thread for it to be considered as solved by the forum software.

Have a great weekend!

3 posts were split to a new topic: Grub shows error: no device specified for hibernation

cat /proc/cmdline

BOOT_IMAGE=/boot/vmlinuz-linux-xanmod-anbox root=UUID=871bbdc4-e5ca-4b84-b75b-da2b12067cce rw acpi_osi=! “acpi_osi=Windows 2009” quiet splash

You have a swap partition in your fstab and a resume device specified in your /etc/default/grub with

UUID=f13268f2-7920-4ce1-866f-b5ecc36ddb5b

which doesn’t show in your kernel’s boot parameters.

Try the following:

sudo mkinitcpio -P

sudo grub-mkconfig -o /boot/grub/grub.cfg

Edit:

If that won’t help, post:

sudo blkid -o list

It didn’t work here is the output you wanted me to enter if that didn’t work https://clbin.com/UoYOe

1 Like

3 posts were merged into an existing topic: Grub shows error: no device specified for hibernation

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.