Suspend not Working and Display Manager Stops after Login


I installed EnOS without any DE/WM because I would like to have a system with AwesomeWM. Thus I installed it (single boot, no window, using the erase disk with SWAP hibernate and btrfs), then I did the steps from the ArchWiki (and following various guides /videos) to reach my objective and I did it. Now I have a very fresh simple working OS with linux-lts, Xorg, AwesomeWM, oh-my-zsh and some minor packages (htop, micro, etc).

Everything works perfectly except for three things:

  • pipewire: I really didn’t find a solution to integrate it with polybar so I switched to pulseaudio (I’m curious why the devs chose pipewire instead of pulseaudio). Apart from my curiosity, no problem anymore here.
  • suspend: when I suspend the system, the system suspends correctly (from journalctl inos), but after hitting any key to resume the session, the journalctl says “-- boot (hex values) --” and the system reboot. I think that this has a similar problem and the solution could help. The problem is that the solution is to update the BIOS firmware and I couldn’t do it (I have an old HP Pavillion dv6 and it seems that now HP gives just an executable for window to update the BIOS). Is there a way to update the BIOS of a HP in linux?
  • display manager: for the moment, I just login via tty and in .xinitrc there’s startx and awesome setup, but I would like a graphical display manager to login. I tried with sddm and now I’m trying with lightdm but they both act the same: they work until I input the correct password. At that point it just never load the session and I have to go in another tty, login, disable the service and reboot. I tried different solutions from the internet, but I understand almost nothing about the infos in the journalctl or the Xorg log. Can you help me find the problem and solve it?

Maybe the two problems are tied together (here’s the reason for one post instead of two), but as I said, I don’t know much to pinpoint the problem.

Here’s the journalctl --since "2 minutes ago" and Xorg.0.log. If you need anything more, just ask me.

The login was done when the clock was approx. 21:47.

Thank you very much!

I’m still here with the same problem, no one can help me?

I changed to EnOS because it’s said that the community is awesome, but I’m here with a broken machine for 40 days without even the slightest sign of help.