Sudo vs run0

Well how are we feeling about using sudo vs run0 (systemd)?
I just started trying to run0 yesterday I guess…it seems to work fine. I know some people think systemd is the devil, and I haven’t really came down on one side of THAT fence yet.
I did want to mention that I have some submitted patches to sudo in the distant past and was very grateful for the reduction in dissemination of the root password in the business where I worked at the time. Always appreciated Todd very much. However, in recent years (for reasons unknown to me), sudo has occasionally seemed to ‘lose it’s shit’ and would not accept my password, and I would have to fall back to ‘su - root’ until I rebooted. I suspect (but never went down rabbit hole) that it was something in the pam modules, perhaps caused by an update without a reboot (tied to other topic I just commented on).
So from that standpoint, I welcome seeing if sudo and run0 fail at the same time, for the same reasons.

1 Like

I dont care that much about the technical background. I can use either command.
But I’m missing some ‘grace time’ for run0 so that you don’t have to reenter the PW that often.

1 Like

Good point, I hadn’t even considered that feature as missing. I’ve only used it a few times at intervals.

I used the -E flag of sudo semi often, so it would be nice to replace that. Howerver, I no longer have to specify the -A flag in order to get the graphical prompt from sudo when using run0.

What about doas? why no love for it :disappointed_relieved:

I didn’t mention it because I don’t use it. You, however, are free to love it.

1 Like

command not found
I can’t love what is not present… :wink:

I think run0 are better solution overall, but I will need to use alias for it, because I’m too used-to to sudo typing.

I’m currently not using run0 yet in practise.

You would need to install and configure doas in order to use it.

https://wiki.archlinux.org/title/Doas
https://aur.archlinux.org/packages/doas

With so many EndeavourOS users (and some Arch users) using yay, does run0 make using yay difficult, or different?

The only issue that I ran into so far with run0 was using meld. There is likely other issues but this is the only one I found.

@Grothesk

opendoas is in Arch’ repo: https://wiki.archlinux.org/title/Doas#Installation

I know that I could install it. But why should I, when sudo and run0 come directly preinstalled?

You shouldn’t if you find it won’t bring anything new to the table for your use case.

Since the subject came up, I put the link here. Not implying that anyone should. I am a happy user of sudo myself. And now I got to play with run0 as well.

3 Likes

sudo env and run0 env are different
with run0:

  • we lose some vars (can sometimes cause problems?)
  • $PATH is not modified (more secure)

Sudo is definitely the more configurable.
I am pretty sure that I contributed code about inheriting ENV as well as a few other things I found needed in my business case use. Is that a security hole, well yes, it can be.

I never use it either lol. I just asked. To me run0 is just a dumb name i’ll probably just make an alias when that time comes. I’ll call it:

2 Likes