Sudo password not working

Hello, I was having this issue with my sudo password not working even though it absolutely was teh correct one (I tested it in plain text). After a few reboots it finally worked again. However, the next day I had the same issue, and I went online.

  1. I saw a really old post, about a different linux system, where someone suggested it could be linked with my systemd-homed. So I used the “systemctl status systemd-homed” command, and it outputed “Active: inactive (dead)”.
  2. So I ran it manually with systemctl enable systemd-homed, and the status changed to this:
    “● systemd-homed.service - Home Area Manager
    Loaded: loaded (/usr/lib/systemd/system/systemd-homed.service; enabled; vendor preset: enabled)
    Active: active (running) since Thu 2021-11-25 08:52:04 -03; 1min 47s ago
    Docs: man:systemd-homed.service(8)
    man:org.freedesktop.home1(5)
    Main PID: 418 (systemd-homed)
    Status: “Processing requests…”
    Tasks: 1 (limit: 9209)
    Memory: 1.3M
    CPU: 35ms
    CGroup: /system.slice/systemd-homed.service
    └─418 /usr/lib/systemd/systemd-homed”
  3. Sudo worked, even though I was made aware after that EOS doesn’t use systemd-homed.

Edit1: I’m using i3, and I sent my journalctl logs.
Edit2: psudo pwd is the same as my user pwd.
Thanks!

Welcome to the forum! :grin:

I never had that problem so can’t really help in that case.

I just see three typos in one short post, sure you are typing the correct one?

Couple of other things that come to my mind:

Type you pwd in plain text first and check that your keyboard settings is correct for your special characters.

What DE are you using? Did you install any pwd manager or similar program recently?

1 Like

What is the source of this information? Have you checked the arch wiki to understand these commands?

Edit: https://wiki.archlinux.org/title/Systemd-homed

Edit 2: I think the problem is most likely something to do with your user, sudoer file and such. If it doesn’t work next time you can try su instead of sudo and login as root.

If it works you will know it’s your user account. The two options would be to create a new user or alternative reinstall your system if you think it’s too difficult. Let’s see if you get any additional solutions posted here. I do not think systemd-homed is your solution.

Yep, the password was correct, sorry for the spelling error, had to do the post in a hurry because I was late for a work meeting.

I edited the posto to include that I’m using i3, and that the password came out correctly in plain text.

Don’t know if that is relevante, but I could sudo setxkbmap, install packages with pacman, or sudo -i. For all of those things, the password came out as wrong

Is your root password the same as your user?

Yes, it is! (edited to include)

So when you use su and this user pwd it is accepted? Try it out…

Yes, it is accepted, at least now after my fix. But I havent rebooted yet.
Edit1: also works after reboot.