Stuttery Lag Fest - Plasma NVIDIA 980TI

I’M using Plasma but unsure whether the performance is solely linked to that so didn’t put in that category

Im using a 3700x & GTX 980Ti
However i am noticing stutteryness in the desktop, whilst resizing windows etc or opening them about 30% of the time is appears as if its resizing in 10fps etc.

I ran nvidia-installer-dkms and rebooted. However it allows me to run it again saying i should install it? Its like its not applied. As i assume this is graphics driver related?

Hello @BumbleTree
Should be no problem on plasma. Are you able to post the link for

inxi -Faz --no-host | eos-sendlog

Looks like the Nvidia driver is installed properly.

Graphics:  Device-1: NVIDIA GM200 [GeForce GTX 980 Ti] vendor: Micro-Star MSI driver: nvidia v: 465.31 
           alternate: nouveau,nvidia_drm bus-ID: 09:00.0 chip-ID: 10de:17c8 class-ID: 0300 
           Display: x11 server: 1.20.11 compositor: kwin_x11 driver: loaded: nvidia 
           resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 

There is some info missing. Would you be able to install the following.

yay -S mesa-demos
yay -S xorg-xdpyinfo

Then run & post

inxi -Ga

Edit@: I just want to verify the module is loading properly.

Graphics: Device-1: NVIDIA GM200 [GeForce GTX 980 Ti] vendor: Micro-Star MSI driver: nvidia v: 465.31
alternate: nouveau,nvidia_drm bus-ID: 09:00.0 chip-ID: 10de:17c8 class-ID: 0300
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 162 s-size: 602x341mm (23.7x13.4") s-diag: 692mm (27.2")
Monitor-1: DP-2 res: 3840x2160 hz: 60 dpi: 163 size: 598x336mm (23.5x13.2") diag: 686mm (27")
OpenGL: renderer: NVIDIA GeForce GTX 980 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 465.31 direct render: Yes

Looks like it’s all correct. So have to think for a bit or someone else come in with some thoughts.

Is this a new install? If so, Plasma can stutter a bit due to baloo, the file indexing service.

Try disabling it by running:

balooctl suspend
balooctl disable

and reboot.

1 Like

I believe this may have fixed it!. Ill give it a short time and then ill mark it as solution or not. Thank you though!

1 Like

baloo never seems to give me a problem. I still have it running. :thinking:

[ricklinux@eos-kde ~]$ balooctl status
Baloo File Indexer is running
Indexer state: Idle
Total files indexed: 118
Files waiting for content indexing: 0
Files failed to index: 0
Current size of index is 6.67 MiB
[ricklinux@eos-kde ~]$ 

Edit: I’m on plasma also but with AMD graphics.

I guess it depends on a case by case basis. I remember several KDE users complaining about baloo here and also on the old manjaro forum (myself included). Of course, I can’t be sure if OP’s problem is related to it, but it’s something worth checking.

1 Like

Well it definitely Helped. However if i for example open a program. Even opening quick settings the entire desktop lags whilst it opens (1-2 secs) (So any movement is a stuttery mess during any app launch, cpu usage etc doesnt spike above 10% so idk)
On a top end NVME SSD btw

It looks like there are three more UEFI Bios updates for that board since v: F50 date: 11/27/2019 . You may want to update to the latest final version at some point.

You may also want to add all the enhancements for the nvidia graphics as per the wiki also.

Edit: These are optional but it helps with issues such as driver updates and modules loading properly. Currently everything looks correct on your system.

There also is a package called kwin-lowlatency in the AUR. I have never used it but i give you the info to look at. Once added it gives a bunch of more settings under compositor which can be left at default except the last one under vsync set to nvidia.

Edit: Her’s a video on it

I added all things in the NVIDIA guide and also updated my bios to latest. Still stuttering.
I just tried installing the low latency program but got

[ 10%] Building CXX object effects/CMakeFiles/kwin4_effect_builtins.dir/blur/blur.cpp.o
/home/myles/kwin-lowlatency/src/kwin-lowlatency/effects/blur/blur.cpp: In constructor ‘KWin::BlurEffect::BlurEffect()’:
/home/myles/kwin-lowlatency/src/kwin-lowlatency/effects/blur/blur.cpp:47:38: error: ‘class KWaylandServer::Display’ has no member named ‘createBlurManager’
47 | m_blurManager = display->createBlurManager(this);
| ^~~~~~~~~~~~~~~~~
make[2]: *** [effects/CMakeFiles/kwin4_effect_builtins.dir/build.make:372: effects/CMakeFiles/kwin4_effect_builtins.dir/blur/blur.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:6507: effects/CMakeFiles/kwin4_effect_builtins.dir/all] Error 2
make: *** [Makefile:136: all] Error 2
==> ERROR: A failure occurred in build().

This is my first linux system as so farm its terrible performance vs windows xD. Isnt it supposed to be the opposite

I’m actually surprised you are having any issues on plasma. I use it myself although I have it installed on an amd system. My Nvidia system has Xfce on it. I see the low latency package didn’t build and install for you. Hmm?

Anyway so you didn’t have any issue’s adding the nvidia enhancements. Did you do all of them on that page?

Yes i did and i saw no obvious errors.

Surely it taking 2 seconds to open the quick settings isnt just the graphics though. Also i seem to be able to out type my keyboard. Aka if i quickly caps lock then off 1 letter. 80% of the time the letter just after taking caps lock off is also caps lock. idk if related

Edit: Okay i realised that if the display is lagged / delayed then there is no way to tell the actual load time therefore it is all probably graphical

What do you mean?

Maybe you should try it on Nouveau and see. Then you could do a reinstall of the nvidia drivers again after in case something is messed up on the install?

Try this and it will install nouveau open source driver for now.

sudo nvidia-installer-dkms -n

Edit: Reboot